aboutsummaryrefslogtreecommitdiff
path: root/sysutils/libgksu/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2011-05-14 18:49:26 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2011-05-14 18:49:26 +0000
commitd79d568a73c0d7080b494b5889ab364d5de987be (patch)
treef48ae69513e8b2f92ea923f2b599fd13eff622d1 /sysutils/libgksu/Makefile
parentad011a097d7591a54d339602615817746ec9ccda (diff)
downloadports-d79d568a73c0d7080b494b5889ab364d5de987be.tar.gz
ports-d79d568a73c0d7080b494b5889ab364d5de987be.zip
Notes
Diffstat (limited to 'sysutils/libgksu/Makefile')
-rw-r--r--sysutils/libgksu/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/sysutils/libgksu/Makefile b/sysutils/libgksu/Makefile
index 7866661a5315..fcfee747224d 100644
--- a/sysutils/libgksu/Makefile
+++ b/sysutils/libgksu/Makefile
@@ -6,22 +6,26 @@
#
PORTNAME= libgksu
-PORTVERSION= 1.3.8
-PORTREVISION= 3
+PORTVERSION= 2.0.9
CATEGORIES= sysutils
-MASTER_SITES= http://people.debian.org/~kov/gksu/old_stuff/libgksu1.2/
-DISTNAME= ${PORTNAME}1.2-${PORTVERSION}
+MASTER_SITES= http://people.debian.org/~kov/gksu/
MAINTAINER= bsam@FreeBSD.org
COMMENT= Library providing su and sudo functionality
+LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop \
+ glade-2.0:${PORTSDIR}/devel/libglade2 \
+ gcr.0:${PORTSDIR}/security/gnome-keyring \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
RUN_DEPENDS= xauth:${PORTSDIR}/x11/xauth \
sudo:${PORTSDIR}/security/sudo
-USE_GNOME= pkgconfig glib20
+USE_GNOME= pkgconfig glib20 gconf2
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-gtk-doc=no
GNU_CONFIGURE= yes
+GCONF_SCHEMAS= gksu.schemas
+USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"