aboutsummaryrefslogtreecommitdiff
path: root/sysutils/liburcu/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2013-06-07 12:36:07 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2013-06-07 12:36:07 +0000
commit346f9b9421fc16a9575dedebc673955dff3fc442 (patch)
treeade64723409c79977879be561cef3835c099100e /sysutils/liburcu/Makefile
parent67a711f6a3ca0792faf8ba36ef7657760c104d55 (diff)
downloadports-346f9b9421fc16a9575dedebc673955dff3fc442.tar.gz
ports-346f9b9421fc16a9575dedebc673955dff3fc442.zip
Notes
Diffstat (limited to 'sysutils/liburcu/Makefile')
-rw-r--r--sysutils/liburcu/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/liburcu/Makefile b/sysutils/liburcu/Makefile
new file mode 100644
index 000000000000..ce533fd8ce01
--- /dev/null
+++ b/sysutils/liburcu/Makefile
@@ -0,0 +1,31 @@
+# Created by: Leo Vandewoestijne <freebsd@dns-lab.com>
+# $FreeBSD$
+
+PORTNAME= liburcu
+PORTVERSION= 0.7.6
+CATEGORIES= sysutils
+MASTER_SITES= http://lttng.org/files/urcu/
+DISTNAME= userspace-rcu-${PORTVERSION}
+
+MAINTAINER= freebsd@dns-lab.com
+COMMENT= Userspace read-copy-update (RCU) data synchronization library
+
+LICENSE= LGPL21
+
+PORTDOCS= ChangeLog README cds-api.txt rcu-api.txt uatomic-api.txt
+
+USES= pathfix
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+= --docdir=${DOCSDIR}
+
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
+
+regression-test: build
+ @cd ${WRKSRC} && ${MAKE} check
+
+.include <bsd.port.mk>