aboutsummaryrefslogtreecommitdiff
path: root/sysutils/linux-f10-procps/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-03-12 10:33:26 +0000
committerRene Ladan <rene@FreeBSD.org>2013-03-12 10:33:26 +0000
commit7af751dc951f97652387d23b8ba93138e18e7755 (patch)
treefdb8bffd40e257474c4ba893122ecc8a45b6da1d /sysutils/linux-f10-procps/Makefile
parente7f539cc4cb8e14c7a3d08b5656ffd7650c6dba9 (diff)
downloadports-7af751dc951f97652387d23b8ba93138e18e7755.tar.gz
ports-7af751dc951f97652387d23b8ba93138e18e7755.zip
Notes
Diffstat (limited to 'sysutils/linux-f10-procps/Makefile')
-rw-r--r--sysutils/linux-f10-procps/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/sysutils/linux-f10-procps/Makefile b/sysutils/linux-f10-procps/Makefile
new file mode 100644
index 000000000000..2a40d214ef65
--- /dev/null
+++ b/sysutils/linux-f10-procps/Makefile
@@ -0,0 +1,26 @@
+# Created by: leres
+# $FreeBSD$
+
+PORTNAME= procps
+PORTVERSION= 3.2.7
+CATEGORIES= sysutils linux
+PKGNAMEPREFIX= linux-f10-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}.fc${LINUX_DIST_VER}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Linux psproc binaries (Linux Fedora 10)
+
+USE_LINUX_RPM= yes
+ONLY_FOR_ARCHS= i386 amd64
+LINUX_DIST_VER= 10
+RPMVERSION= 21
+USE_LDCONFIG= yes
+BRANDELF_DIRS= bin sbin usr/bin
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+PROCFS= /compat/linux/proc
+
+post-install:
+ @df ${PROCFS} 2>&1 | ${EGREP} '^linprocfs ' > /dev/null 2>&1 || (echo ">>>" ; echo ">>> You still need to mount ${PROCFS}; see linprocfs(5)" ; echo ">>> for more information" ; echo ">>>")
+
+.include <bsd.port.mk>