aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lxinput/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-10-04 22:36:31 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-10-04 22:36:31 +0000
commit9888b66a3c47814a05e96913c5850c82828b983a (patch)
treeb20a58e89b9c9610e1995f5c126e887eac85d577 /sysutils/lxinput/Makefile
parent6594dedb7264264275a28ef34dd42f5f4624373f (diff)
downloadports-9888b66a3c47814a05e96913c5850c82828b983a.tar.gz
ports-9888b66a3c47814a05e96913c5850c82828b983a.zip
Notes
Diffstat (limited to 'sysutils/lxinput/Makefile')
-rw-r--r--sysutils/lxinput/Makefile29
1 files changed, 18 insertions, 11 deletions
diff --git a/sysutils/lxinput/Makefile b/sysutils/lxinput/Makefile
index 793b58ff4bd8..53cd1e602e2a 100644
--- a/sysutils/lxinput/Makefile
+++ b/sysutils/lxinput/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 0.3.2
CATEGORIES= sysutils
MASTER_SITES= SF/lxde/LXInput%20%28Kbd%20and%20amp_%20mouse%20config%29/LXInput%200.3.2/
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Keyboard and mouse config tool from the LXDE project
USES= iconv gmake pkgconfig
@@ -15,19 +15,26 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
-MAN1= lxinput.1
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= AUTHORS README
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
+post-patch:
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e 's|po man|man|' \
+ ${WRKSRC}/Makefile.in
.endif
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>