aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lxinput/Makefile
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2010-09-30 14:34:47 +0000
committerKris Moore <kmoore@FreeBSD.org>2010-09-30 14:34:47 +0000
commitf49a55d2d2f3c2b34a9c5217ee61ece15387bf5d (patch)
treef400bb571894bc58e10df049eedb2abe8ce3b70d /sysutils/lxinput/Makefile
parent37db11c7cc8b7662949911eb215b7d409465c74d (diff)
downloadports-f49a55d2d2f3c2b34a9c5217ee61ece15387bf5d.tar.gz
ports-f49a55d2d2f3c2b34a9c5217ee61ece15387bf5d.zip
Notes
Diffstat (limited to 'sysutils/lxinput/Makefile')
-rw-r--r--sysutils/lxinput/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/lxinput/Makefile b/sysutils/lxinput/Makefile
new file mode 100644
index 000000000000..48ecff6bbf8b
--- /dev/null
+++ b/sysutils/lxinput/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lxinput
+# Date created: 2010/09/24
+# Whom: Kris Moore <kmoore@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lxinput
+PORTVERSION= 0.3.0
+CATEGORIES= sysutils
+MASTER_SITES= SF/lxde/LXInput%20%28Kbd%20and%20amp_%20mouse%20config%29/LXInput%200.3
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= A keyboard and mouse config tool from the LXDE project
+
+USE_GNOME= gtk20 intlhack
+USE_GMAKE= yes
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+MAN1= lxinput.1
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>