aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mcollective-actionpolicy-auth
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2016-03-24 20:30:33 +0000
committerRomain Tartière <romain@FreeBSD.org>2016-03-24 20:30:33 +0000
commitaceddd804320587fa4208c48da1dffa0aac547b5 (patch)
tree91e034272b1518b2a9edd069b9c7d42e7fcbe1ff /sysutils/mcollective-actionpolicy-auth
parent4a68b19d0edc8c626a1c22add11d7a78b9262065 (diff)
downloadports-aceddd804320587fa4208c48da1dffa0aac547b5.tar.gz
ports-aceddd804320587fa4208c48da1dffa0aac547b5.zip
This is a plugin that provides fine grained action level authorization for
agents. Any MCollective agent plugins based on SimpleRPC can be restricted with authorization plugins like this one. WWW: https://github.com/puppetlabs/mcollective-actionpolicy-auth
Notes
Notes: svn path=/head/; revision=411810
Diffstat (limited to 'sysutils/mcollective-actionpolicy-auth')
-rw-r--r--sysutils/mcollective-actionpolicy-auth/Makefile31
-rw-r--r--sysutils/mcollective-actionpolicy-auth/distinfo2
-rw-r--r--sysutils/mcollective-actionpolicy-auth/files/pkg-message.in7
-rw-r--r--sysutils/mcollective-actionpolicy-auth/pkg-descr5
4 files changed, 45 insertions, 0 deletions
diff --git a/sysutils/mcollective-actionpolicy-auth/Makefile b/sysutils/mcollective-actionpolicy-auth/Makefile
new file mode 100644
index 000000000000..1b5b96fe2241
--- /dev/null
+++ b/sysutils/mcollective-actionpolicy-auth/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= mcollective-actionpolicy-auth
+PORTVERSION= 2.1.0
+CATEGORIES= sysutils
+
+MAINTAINER= romain@FreeBSD.org
+COMMENT= MCollective Authorization plugin allowing fine grained ACLs
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= mcollective>=2:${PORTSDIR}/sysutils/mcollective
+
+USE_GITHUB= yes
+GH_ACCOUNT= puppetlabs
+SUB_FILES= pkg-message
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= share/mcollective/util/actionpolicy.ddl \
+ share/mcollective/util/actionpolicy.rb
+PLIST_DIRS= etc/mcollective/policies
+
+.if !target(do-install)
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "util" ${STAGEDIR}${PREFIX}/share/mcollective
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/mcollective/policies
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/mcollective-actionpolicy-auth/distinfo b/sysutils/mcollective-actionpolicy-auth/distinfo
new file mode 100644
index 000000000000..fb1325d71762
--- /dev/null
+++ b/sysutils/mcollective-actionpolicy-auth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (puppetlabs-mcollective-actionpolicy-auth-2.1.0_GH0.tar.gz) = e824a8c98c3ef3efcb723a0d0983c7a17e68a5d34646fd303bf1d8d221f76d58
+SIZE (puppetlabs-mcollective-actionpolicy-auth-2.1.0_GH0.tar.gz) = 11900
diff --git a/sysutils/mcollective-actionpolicy-auth/files/pkg-message.in b/sysutils/mcollective-actionpolicy-auth/files/pkg-message.in
new file mode 100644
index 000000000000..46351464a02b
--- /dev/null
+++ b/sysutils/mcollective-actionpolicy-auth/files/pkg-message.in
@@ -0,0 +1,7 @@
+************************************************************************
+Add the following lines to %%PREFIX%%/etc/mcollective/server.cfg to
+enable the mcollective-actionpolicy-auth plugin:
+
+rpcauthorization = 1
+rpcauthprovider = action_policy
+************************************************************************
diff --git a/sysutils/mcollective-actionpolicy-auth/pkg-descr b/sysutils/mcollective-actionpolicy-auth/pkg-descr
new file mode 100644
index 000000000000..0a1a790b698d
--- /dev/null
+++ b/sysutils/mcollective-actionpolicy-auth/pkg-descr
@@ -0,0 +1,5 @@
+This is a plugin that provides fine grained action level authorization for
+agents. Any MCollective agent plugins based on SimpleRPC can be restricted with
+authorization plugins like this one.
+
+WWW: https://github.com/puppetlabs/mcollective-actionpolicy-auth