aboutsummaryrefslogtreecommitdiff
path: root/sysutils/memgrep/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-01-04 20:36:52 +0000
committerClement Laforet <clement@FreeBSD.org>2004-01-04 20:36:52 +0000
commitfab68c1b1665650401cfe2c08c76f136ed93a300 (patch)
tree2cd24b03f6098f6cc12c069f34b5def12190268e /sysutils/memgrep/Makefile
parentb225fea83c8bfe1fa217cd0fb8f890dac511d316 (diff)
downloadports-fab68c1b1665650401cfe2c08c76f136ed93a300.tar.gz
ports-fab68c1b1665650401cfe2c08c76f136ed93a300.zip
Notes
Diffstat (limited to 'sysutils/memgrep/Makefile')
-rw-r--r--sysutils/memgrep/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/sysutils/memgrep/Makefile b/sysutils/memgrep/Makefile
index 326ec485b1fb..8094d966a822 100644
--- a/sysutils/memgrep/Makefile
+++ b/sysutils/memgrep/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= memgrep
-PORTVERSION= 0.7.0
+PORTVERSION= 0.8.0
CATEGORIES= sysutils
MASTER_SITES= http://www.hick.org/code/skape/memgrep/
@@ -15,13 +15,29 @@ COMMENT= Utility to manipulate memory from running processes and core files
HAS_CONFIGURE= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
+PORTDOCS= annotated.html doxygen.css doxygen.png examples.html files.html \
+ functions.html group__memgrep.html index.html memgrep_8h-source.html \
+ modules.html simple_8c-example.html struct__core__memory__sections.html \
+ struct__mem__ctx.html struct__mem__ctx__core__data.html \
+ struct__memgrep__functions.html struct__memgrep__result.html\
+ struct__memgrep__result__row.html struct__memgrep__result__row__dump.html \
+ struct__memgrep__result__row__heap.html \
+ struct__memgrep__result__row__replace.html \
+ struct__memgrep__result__row__search.html struct__process__section__addrs.html
+
+post-patch:
+ @${REINPLACE_CMD} "s,-O3,,;s,FLAGS=,FLAGS+=," ${WRKSRC}/src/Makefile.in ${WRKSRC}/examples/Makefile.in
+
+MAKE_ENV+= FLAGS="${CFLAGS}"
+
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/docs/html/* ${DOCSDIR}/html
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/html/* ${DOCSDIR}
.endif
.include <bsd.port.mk>