aboutsummaryrefslogtreecommitdiff
path: root/sysutils/memtest86+
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-03-24 00:52:35 +0000
committerSteve Wills <swills@FreeBSD.org>2014-03-24 00:52:35 +0000
commitb89a4706bdc8f36b7d1e0f7b8d1fc409478ccb53 (patch)
tree59aaca19676a6a441e71cd716137276806601b88 /sysutils/memtest86+
parent581ad3f9ec437ddb0c9e01ab40bd60b8cc3eabf4 (diff)
downloadports-b89a4706bdc8f36b7d1e0f7b8d1fc409478ccb53.tar.gz
ports-b89a4706bdc8f36b7d1e0f7b8d1fc409478ccb53.zip
- Stagify
- Replace USE_GMAKE and USE_DOS2UNIX with respective USES= - Add USE_GCC= yes, as it won't build with clang34 PR: ports/187415 Submitted by: Johannes Jost Meixner <xmj@chaot.net> Approved by: Andriy Gapon <avg@icyb.net.ua> (maintainer)
Notes
Notes: svn path=/head/; revision=348915
Diffstat (limited to 'sysutils/memtest86+')
-rw-r--r--sysutils/memtest86+/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/sysutils/memtest86+/Makefile b/sysutils/memtest86+/Makefile
index 715d28f84692..2d4fbdf4b45a 100644
--- a/sysutils/memtest86+/Makefile
+++ b/sysutils/memtest86+/Makefile
@@ -3,7 +3,7 @@
PORTNAME= memtest86+
PORTVERSION= 4.20
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://www.memtest.org/download/${PORTVERSION}/
@@ -12,11 +12,12 @@ COMMENT= Stand-alone memory test for x86 architecture computers
ONLY_FOR_ARCHS= i386 amd64
-USE_DOS2UNIX= README memtest.lds setup.S
-USE_GMAKE= yes
+USES= gmake dos2unix
ALL_TARGET= all
PORTDOCS= *
+USE_GCC= yes
+
# Please provide absolute path below (cannot be root)
BOOT_DIR?= /boot/opt
@@ -29,7 +30,6 @@ BOOT_DESC= Build ELF image loadable by boot2 and loader
SERIAL_DESC= Enable serial console at COM1/9600
HISPEED_DESC= Set COM1 serial console speed to 115200
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MBOOT}
@@ -59,6 +59,9 @@ pre-fetch:
@${ECHO} "build ISO image with custom tweaks in memtest86+ code."
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
+
PLIST= ${WRKDIR}/pkg-plist
pre-install:
@@ -76,17 +79,17 @@ pre-install:
do-install:
.if ${PORT_OPTIONS:MISO}
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/mt${PORTVERSION:C/\.//}.iso ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/mt${PORTVERSION:C/\.//}.iso ${STAGEDIR}${DATADIR}
.endif
.if ${PORT_OPTIONS:MBOOT}
- @${MKDIR} ${BOOT_DIR}
+ @${MKDIR} ${STAGEDIR}${BOOT_DIR}
# XXX is INSTALL_KLD really appropriate here? XXX
- ${INSTALL_KLD} ${WRKSRC}/memtest ${BOOT_DIR}/memtest86+
+ ${INSTALL_KLD} ${WRKSRC}/memtest ${STAGEDIR}${BOOT_DIR}/memtest86+
.endif
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
post-install: