aboutsummaryrefslogtreecommitdiff
path: root/sysutils/memtest
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-07-19 10:27:53 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-07-19 10:27:53 +0000
commita8dbb774215dff620e6f3d1560cdd027ebe3284c (patch)
treeef0570a4943b24334e67a9a4f4aa30f2a88620bd /sysutils/memtest
parentc02cba49bd6c454e73f15ee0cc27803d1f2ad324 (diff)
downloadports-a8dbb774215dff620e6f3d1560cdd027ebe3284c.tar.gz
ports-a8dbb774215dff620e6f3d1560cdd027ebe3284c.zip
Notes
Diffstat (limited to 'sysutils/memtest')
-rw-r--r--sysutils/memtest/Makefile25
-rw-r--r--sysutils/memtest/distinfo1
-rw-r--r--sysutils/memtest/files/patch-aa10
-rw-r--r--sysutils/memtest/files/patch-ab13
-rw-r--r--sysutils/memtest/pkg-comment1
-rw-r--r--sysutils/memtest/pkg-descr9
-rw-r--r--sysutils/memtest/pkg-plist1
7 files changed, 60 insertions, 0 deletions
diff --git a/sysutils/memtest/Makefile b/sysutils/memtest/Makefile
new file mode 100644
index 000000000000..f57287e630c7
--- /dev/null
+++ b/sysutils/memtest/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: memtest
+# Date created: 18 Jun 2000
+# Whom: Mario S F Ferreira <lioux@linf.unb.br> et al.
+#
+# $FreeBSD$
+#
+
+PORTNAME= memtest
+PORTVERSION= 2.93.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.qcc.sk.ca/~charlesc/software/memtester/
+DISTNAME= ${PORTNAME}er-${PORTVERSION}
+
+MAINTAINER= lioux@linf.unb.br
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+MAN1= ${PORTNAME}.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/memtest/distinfo b/sysutils/memtest/distinfo
new file mode 100644
index 000000000000..529408f3a459
--- /dev/null
+++ b/sysutils/memtest/distinfo
@@ -0,0 +1 @@
+MD5 (memtester-2.93.1.tar.bz2) = 3c971e11ca71cc8cd9d43b247170c243
diff --git a/sysutils/memtest/files/patch-aa b/sysutils/memtest/files/patch-aa
new file mode 100644
index 000000000000..33aa4b187437
--- /dev/null
+++ b/sysutils/memtest/files/patch-aa
@@ -0,0 +1,10 @@
+--- memtest.c.orig Tue Jul 18 22:13:31 2000
++++ memtest.c Tue Jul 18 22:13:58 2000
+@@ -20,6 +20,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <time.h>
++#include <sys/types.h>
+ #include <sys/mman.h>
+ #include <signal.h>
+ #include <unistd.h>
diff --git a/sysutils/memtest/files/patch-ab b/sysutils/memtest/files/patch-ab
new file mode 100644
index 000000000000..7027a28e13ca
--- /dev/null
+++ b/sysutils/memtest/files/patch-ab
@@ -0,0 +1,13 @@
+--- memtest.1.orig Wed Apr 26 19:58:23 2000
++++ memtest.1 Tue Jul 18 22:37:20 2000
+@@ -196,7 +196,9 @@
+ faulty memory modules in Linux, or any Unix-like environment.
+ .Sh "Invoking memtest"
+ \fBmemtest\fR takes the first supplied argument as the amount of memory to test.
+-The value \fB'all\*(R'\fR means to test all available memory. A specific amount of
++The value \fB'all\*(R'\fR means to test all available memory. However, the value \fB'all\*(R'\fR
++may not work on all systems, so a specific amount of memory might have to
++be specified. A specific amount of
+ memory can be supplied as a number, followed by a letter to indicate units:
+ .Ip "\(bu" 4
+ \fBB\fR or \fBb\fR \- bytes
diff --git a/sysutils/memtest/pkg-comment b/sysutils/memtest/pkg-comment
new file mode 100644
index 000000000000..78b0d0d04976
--- /dev/null
+++ b/sysutils/memtest/pkg-comment
@@ -0,0 +1 @@
+Utility to test for faulty memory subsystem
diff --git a/sysutils/memtest/pkg-descr b/sysutils/memtest/pkg-descr
new file mode 100644
index 000000000000..f51fc22d684d
--- /dev/null
+++ b/sysutils/memtest/pkg-descr
@@ -0,0 +1,9 @@
+memtest is a utility for testing the memory subsystem in a computer
+to determine if it is faulty. The original source was by Simon
+Kirby <sim@stormix.com>. The program has been rewritten by Charles
+Cazabon and many additional tests were added to help catch borderline
+memory. He also rewrote the original tests (which catch mainly
+memory bits which are stuck permanently high or low) so that they
+run approximately an order of magnitude faster.
+
+WWW: http://www.qcc.sk.ca/~charlesc/software/memtester/
diff --git a/sysutils/memtest/pkg-plist b/sysutils/memtest/pkg-plist
new file mode 100644
index 000000000000..53671aabd9db
--- /dev/null
+++ b/sysutils/memtest/pkg-plist
@@ -0,0 +1 @@
+bin/memtest