aboutsummaryrefslogtreecommitdiff
path: root/sysutils/memtester
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-04-09 17:06:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-04-09 17:06:46 +0000
commitb0229ddc84e2e8bbe219e188c38ac162ff43b876 (patch)
treeca9a039f7a014c7f8be6fbfef037a7d4fee2ff6d /sysutils/memtester
parent96c4a6fb54b361be281ba571c59c1a9053abbec7 (diff)
downloadports-b0229ddc84e2e8bbe219e188c38ac162ff43b876.tar.gz
ports-b0229ddc84e2e8bbe219e188c38ac162ff43b876.zip
- Rename sysutils/memtest to sysutils/memtester as that's how the
package and upstream project are named - Take maintainership
Notes
Notes: svn path=/head/; revision=466869
Diffstat (limited to 'sysutils/memtester')
-rw-r--r--sysutils/memtester/Makefile27
-rw-r--r--sysutils/memtester/distinfo2
-rw-r--r--sysutils/memtester/pkg-descr13
3 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/memtester/Makefile b/sysutils/memtester/Makefile
new file mode 100644
index 000000000000..b36cd824399e
--- /dev/null
+++ b/sysutils/memtester/Makefile
@@ -0,0 +1,27 @@
+# Created by: Mario S F Ferreira <lioux@linf.unb.br> et al.
+# $FreeBSD$
+
+PORTNAME= memtester
+PORTVERSION= 4.3.0
+CATEGORIES= sysutils
+MASTER_SITES= http://pyropus.ca/software/${PORTNAME}/old-versions/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Utility to test for faulty memory subsystem
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+PLIST_FILES= bin/${PORTNAME} man/man8/${PORTNAME}.8.gz
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|cc|${CC}|' \
+ ${WRKSRC}/conf-*
+ @${REINPLACE_CMD} -e 's|_SC_PAGE_SIZE|_SC_PAGESIZE|' \
+ ${WRKSRC}/${PORTNAME}.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${STAGEDIR}${MANPREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/sysutils/memtester/distinfo b/sysutils/memtester/distinfo
new file mode 100644
index 000000000000..f56a67b31d89
--- /dev/null
+++ b/sysutils/memtester/distinfo
@@ -0,0 +1,2 @@
+SHA256 (memtester-4.3.0.tar.gz) = f9dfe2fd737c38fad6535bbab327da9a21f7ce4ea6f18c7b3339adef6bf5fd88
+SIZE (memtester-4.3.0.tar.gz) = 22113
diff --git a/sysutils/memtester/pkg-descr b/sysutils/memtester/pkg-descr
new file mode 100644
index 000000000000..b8c9524fff13
--- /dev/null
+++ b/sysutils/memtester/pkg-descr
@@ -0,0 +1,13 @@
+A user-space utility for testing the memory subsystem for faults. It is
+portable and should compile and work on any 32- or 64-bit Unix-like system.
+(Yes, even weird, proprietary Unices, and even Mac OS X.) For hardware
+developers, memtester can be told to test memory starting at a particular
+physical address as of memtester version 4.1.0.
+
+The original source was by Simon Kirby <sim@stormix.com>. The program has
+been rewritten by Charles Cazabon and many additional tests were added to
+help catch borderline memory. He also rewrote the original tests (which
+catch mainly memory bits which are stuck permanently high or low) so that
+they run approximately an order of magnitude faster.
+
+WWW: http://pyropus.ca/software/memtester/