aboutsummaryrefslogtreecommitdiff
path: root/sysutils/minikube
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-12-25 22:04:20 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-12-25 22:04:20 +0000
commit53de4e4b5da6c6fe45ef75eccfd069ea184cb430 (patch)
tree1ae735c3dd4c057a7a986aad92c2b69a7b786a65 /sysutils/minikube
parente86c4e0abba889cd232ea3c631f93ef28f6ac892 (diff)
downloadports-53de4e4b5da6c6fe45ef75eccfd069ea184cb430.tar.gz
ports-53de4e4b5da6c6fe45ef75eccfd069ea184cb430.zip
- Update to 0.32.0
- Use symlinks for OS dependent files which don't need changes instead of keep them in files/
Notes
Notes: svn path=/head/; revision=488351
Diffstat (limited to 'sysutils/minikube')
-rw-r--r--sysutils/minikube/Makefile13
-rw-r--r--sysutils/minikube/distinfo6
-rw-r--r--sysutils/minikube/files/patch-pkg_minikube_cluster_cluster__freebsd.go32
-rw-r--r--sysutils/minikube/files/patch-third__party_go9p_srv__pipe__freebsd.go44
-rw-r--r--sysutils/minikube/files/patch-vendor_github.com_pkg_browser_browser__unsupported.go8
5 files changed, 22 insertions, 81 deletions
diff --git a/sysutils/minikube/Makefile b/sysutils/minikube/Makefile
index 75a5f2192028..8d0382018431 100644
--- a/sysutils/minikube/Makefile
+++ b/sysutils/minikube/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= minikube
-PORTVERSION= 0.30.0
+PORTVERSION= 0.32.0
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
@@ -22,13 +22,22 @@ GH_ACCOUNT= kubernetes
GO_PKGNAME= k8s.io/${PORTNAME}
GO_TARGET= ${GO_PKGNAME}/cmd/${PORTNAME}
GO_BUILDFLAGS= -ldflags="-X k8s.io/minikube/pkg/version.version=v${PORTVERSION} \
- -X k8s.io/minikube/pkg/version.isoVersion=v0.30.0 \
+ -X k8s.io/minikube/pkg/version.isoVersion=v0.32.0 \
-X k8s.io/minikube/pkg/version.isoPath=minikube/iso"
PLIST_FILES= bin/${PORTNAME}
SUB_FILES= pkg-message
+post-patch:
+ cd ${WRKSRC}/pkg/minikube/tunnel && \
+ ${LN} -s route_darwin.go route_freebsd.go
+ cd ${WRKSRC}/vendor/github.com/pkg/browser && \
+ ${LN} -s browser_linux.go browser_freebsd.go
+ cd ${WRKSRC}/pkg/minikube/cluster && \
+ ${LN} -s cluster_linux.go cluster_freebsd.go
+ cd ${WRKSRC}/third_party/go9p && \
+ ${LN} -s srv_pipe_linux.go srv_pipe_freebsd.go
pre-build:
cd ${WRKSRC} && \
${LOCALBASE}/bin/go-bindata -nomemcopy \
diff --git a/sysutils/minikube/distinfo b/sysutils/minikube/distinfo
index 2671433852c9..9e755cca1798 100644
--- a/sysutils/minikube/distinfo
+++ b/sysutils/minikube/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1538816046
-SHA256 (kubernetes-minikube-v0.30.0_GH0.tar.gz) = 6bc598b9ca46ecc168cbcc8594fed04d841c146050ce7f891910e3ccfa9b76ad
-SIZE (kubernetes-minikube-v0.30.0_GH0.tar.gz) = 9180859
+TIMESTAMP = 1545599458
+SHA256 (kubernetes-minikube-v0.32.0_GH0.tar.gz) = 0b6bd102460c551159c26b5c56a5be97d39b614c0b1b8afa43f3dfed0c20a02c
+SIZE (kubernetes-minikube-v0.32.0_GH0.tar.gz) = 9216759
diff --git a/sysutils/minikube/files/patch-pkg_minikube_cluster_cluster__freebsd.go b/sysutils/minikube/files/patch-pkg_minikube_cluster_cluster__freebsd.go
deleted file mode 100644
index d2bcd1a172c4..000000000000
--- a/sysutils/minikube/files/patch-pkg_minikube_cluster_cluster__freebsd.go
+++ /dev/null
@@ -1,32 +0,0 @@
---- pkg/minikube/cluster/cluster_freebsd.go.orig 2018-08-08 17:03:34 UTC
-+++ pkg/minikube/cluster/cluster_freebsd.go
-@@ -0,0 +1,29 @@
-+/*
-+Copyright 2016 The Kubernetes Authors All rights reserved.
-+
-+Licensed under the Apache License, Version 2.0 (the "License");
-+you may not use this file except in compliance with the License.
-+You may obtain a copy of the License at
-+
-+ http://www.apache.org/licenses/LICENSE-2.0
-+
-+Unless required by applicable law or agreed to in writing, software
-+distributed under the License is distributed on an "AS IS" BASIS,
-+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-+See the License for the specific language governing permissions and
-+limitations under the License.
-+*/
-+
-+package cluster
-+
-+import (
-+ "os/exec"
-+)
-+
-+func detectVBoxManageCmd() string {
-+ cmd := "VBoxManage"
-+ if path, err := exec.LookPath(cmd); err == nil {
-+ return path
-+ }
-+ return cmd
-+}
diff --git a/sysutils/minikube/files/patch-third__party_go9p_srv__pipe__freebsd.go b/sysutils/minikube/files/patch-third__party_go9p_srv__pipe__freebsd.go
deleted file mode 100644
index c8144de0568b..000000000000
--- a/sysutils/minikube/files/patch-third__party_go9p_srv__pipe__freebsd.go
+++ /dev/null
@@ -1,44 +0,0 @@
---- third_party/go9p/srv_pipe_freebsd.go.orig 2018-08-08 16:59:53 UTC
-+++ third_party/go9p/srv_pipe_freebsd.go
-@@ -0,0 +1,41 @@
-+// Copyright 2009 The go9p Authors. All rights reserved.
-+// Use of this source code is governed by a BSD-style
-+// license that can be found in the LICENSE file.
-+
-+package go9p
-+
-+import (
-+ "fmt"
-+ "os"
-+ "syscall"
-+)
-+
-+func (dir *pipeDir) dotu(path string, d os.FileInfo, upool Users, sysMode *syscall.Stat_t) {
-+ u := upool.Uid2User(int(sysMode.Uid))
-+ g := upool.Gid2Group(int(sysMode.Gid))
-+ dir.Uid = u.Name()
-+ if dir.Uid == "" {
-+ dir.Uid = "none"
-+ }
-+
-+ dir.Gid = g.Name()
-+ if dir.Gid == "" {
-+ dir.Gid = "none"
-+ }
-+ dir.Muid = "none"
-+ dir.Ext = ""
-+ dir.Uidnum = uint32(u.Id())
-+ dir.Gidnum = uint32(g.Id())
-+ dir.Muidnum = NOUID
-+ if d.Mode()&os.ModeSymlink != 0 {
-+ var err error
-+ dir.Ext, err = os.Readlink(path)
-+ if err != nil {
-+ dir.Ext = ""
-+ }
-+ } else if isBlock(d) {
-+ dir.Ext = fmt.Sprintf("b %d %d", sysMode.Rdev>>24, sysMode.Rdev&0xFFFFFF)
-+ } else if isChar(d) {
-+ dir.Ext = fmt.Sprintf("c %d %d", sysMode.Rdev>>24, sysMode.Rdev&0xFFFFFF)
-+ }
-+}
diff --git a/sysutils/minikube/files/patch-vendor_github.com_pkg_browser_browser__unsupported.go b/sysutils/minikube/files/patch-vendor_github.com_pkg_browser_browser__unsupported.go
new file mode 100644
index 000000000000..37035f2505a2
--- /dev/null
+++ b/sysutils/minikube/files/patch-vendor_github.com_pkg_browser_browser__unsupported.go
@@ -0,0 +1,8 @@
+--- vendor/github.com/pkg/browser/browser_unsupported.go.orig 2018-12-25 00:08:26 UTC
++++ vendor/github.com/pkg/browser/browser_unsupported.go
+@@ -1,4 +1,4 @@
+-// +build !linux,!windows,!darwin
++// +build !linux,!windows,!darwin,!freebsd
+
+ package browser
+