aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mixer
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-02-20 05:38:44 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-02-20 05:38:44 +0000
commit0a37121ca4245e24b2df7fc225c6d595ae330df0 (patch)
treed72176bcf9cda6e0cfbe1b44638bce12f1a52328 /sysutils/mixer
parent714747d291df5e60f4dd711a2f4b1f0defa9256e (diff)
downloadports-0a37121ca4245e24b2df7fc225c6d595ae330df0.tar.gz
ports-0a37121ca4245e24b2df7fc225c6d595ae330df0.zip
Add mixer 1.0, a startup/shutdown script to preserve mixer settings
across reboots. PR: 35028 Submitted by: Mike Meyer <mwm@mired.org>
Notes
Notes: svn path=/head/; revision=54941
Diffstat (limited to 'sysutils/mixer')
-rw-r--r--sysutils/mixer/Makefile22
-rw-r--r--sysutils/mixer/files/mixer.sh17
-rw-r--r--sysutils/mixer/pkg-comment1
-rw-r--r--sysutils/mixer/pkg-descr3
-rw-r--r--sysutils/mixer/pkg-plist1
5 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/mixer/Makefile b/sysutils/mixer/Makefile
new file mode 100644
index 000000000000..8e37d5c96e0a
--- /dev/null
+++ b/sysutils/mixer/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: mixer
+# Date created: 17 February 2002
+# Whom: Mike Meyer <mwm@mired.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mixer
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= mwm@mired.org
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${FILESDIR}/mixer.sh ${PREFIX}/etc/rc.d
+
+.include <bsd.port.mk>
diff --git a/sysutils/mixer/files/mixer.sh b/sysutils/mixer/files/mixer.sh
new file mode 100644
index 000000000000..3967b54fe93d
--- /dev/null
+++ b/sysutils/mixer/files/mixer.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+# $FreeBSD$
+
+MIXERSTATE=/var/db/mixer-state
+
+case $1 in
+start)
+ [ -r $MIXERSTATE ] && /usr/sbin/mixer `cat $MIXERSTATE` > /dev/null
+ ;;
+stop)
+ /usr/sbin/mixer -s > $MIXERSTATE
+ ;;
+*)
+ echo "usage: `basename $0` {start|stop}" >&2
+ exit 64
+ ;;
+esac
diff --git a/sysutils/mixer/pkg-comment b/sysutils/mixer/pkg-comment
new file mode 100644
index 000000000000..bb70d4137d5e
--- /dev/null
+++ b/sysutils/mixer/pkg-comment
@@ -0,0 +1 @@
+A startup/shutdown script to preserve mixer settings across reboots
diff --git a/sysutils/mixer/pkg-descr b/sysutils/mixer/pkg-descr
new file mode 100644
index 000000000000..1cd92dc4849e
--- /dev/null
+++ b/sysutils/mixer/pkg-descr
@@ -0,0 +1,3 @@
+This port installs a simple shellscript in ${PREFIX}/etc/rc.d that saves
+the state of the mixer when the system is shut down, and restores it when
+the system is rebooted.
diff --git a/sysutils/mixer/pkg-plist b/sysutils/mixer/pkg-plist
new file mode 100644
index 000000000000..524faaca5e98
--- /dev/null
+++ b/sysutils/mixer/pkg-plist
@@ -0,0 +1 @@
+etc/rc.d/mixer.sh