aboutsummaryrefslogtreecommitdiff
path: root/sysutils/moreutils
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-01-01 20:58:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-01-01 20:58:37 +0000
commit74e2acf213fcf430c1b19ea741cc7e0c19d909de (patch)
tree669eb7aa5be277410d2d892d332f320340afa6d8 /sysutils/moreutils
parent32e58a9d0f6b57aaddb6f6542bf185c4aac405ef (diff)
downloadports-74e2acf213fcf430c1b19ea741cc7e0c19d909de.tar.gz
ports-74e2acf213fcf430c1b19ea741cc7e0c19d909de.zip
Update to 0.62
Notes
Notes: svn path=/head/; revision=457800
Diffstat (limited to 'sysutils/moreutils')
-rw-r--r--sysutils/moreutils/Makefile2
-rw-r--r--sysutils/moreutils/distinfo6
-rw-r--r--sysutils/moreutils/files/patch-pee.c10
-rw-r--r--sysutils/moreutils/files/pee.128
4 files changed, 38 insertions, 8 deletions
diff --git a/sysutils/moreutils/Makefile b/sysutils/moreutils/Makefile
index ef87462f2be8..f161b0d5bf32 100644
--- a/sysutils/moreutils/Makefile
+++ b/sysutils/moreutils/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= moreutils
-PORTVERSION= 0.61
+PORTVERSION= 0.62
CATEGORIES= sysutils
MASTER_SITES= https://git.joeyh.name/index.cgi/moreutils.git/snapshot/ \
LOCAL/sunpoet
diff --git a/sysutils/moreutils/distinfo b/sysutils/moreutils/distinfo
index 1c64aff62e08..af9c8a058736 100644
--- a/sysutils/moreutils/distinfo
+++ b/sysutils/moreutils/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1493551321
-SHA256 (moreutils-0.61.tar.gz) = eb47d33251715a8638c2309ab69b23e9023f7fd2fe2c101c9574230e91ff308b
-SIZE (moreutils-0.61.tar.gz) = 91205
+TIMESTAMP = 1514822918
+SHA256 (moreutils-0.62.tar.gz) = 9ddf9d74983bbca869de96210c81b95ef747d817bce67505f9804a90b9ce83bd
+SIZE (moreutils-0.62.tar.gz) = 92303
diff --git a/sysutils/moreutils/files/patch-pee.c b/sysutils/moreutils/files/patch-pee.c
new file mode 100644
index 000000000000..2293c54eb1f0
--- /dev/null
+++ b/sysutils/moreutils/files/patch-pee.c
@@ -0,0 +1,10 @@
+--- pee.c.orig 2017-12-31 16:02:11 UTC
++++ pee.c
+@@ -2,6 +2,7 @@
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <string.h>
++#include <signal.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <errno.h>
diff --git a/sysutils/moreutils/files/pee.1 b/sysutils/moreutils/files/pee.1
index 026a8650479e..a752549c199b 100644
--- a/sysutils/moreutils/files/pee.1
+++ b/sysutils/moreutils/files/pee.1
@@ -2,12 +2,12 @@
.\" Title: pee
.\" Author: Joey Hess
.\" Generator: DocBook XSL Stylesheets v1.76.1 <http://docbook.sf.net/>
-.\" Date: 2006-03-14
+.\" Date: 2016-12-20
.\" Manual: moreutils
.\" Source: moreutils
.\" Language: English
.\"
-.TH "PEE" "1" "2006\-03\-14" "moreutils" "moreutils"
+.TH "PEE" "1" "2016\-12\-20" "moreutils" "moreutils"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
@@ -31,7 +31,7 @@
pee \- tee standard input to pipes
.SH "SYNOPSIS"
.HP \w'\fBpee\fR\ 'u
-\fBpee\fR [[\fI"command"\fR...]]
+\fBpee\fR [\-\-[no\-]ignore\-sigpipe] [\-\-[no\-]ignore\-write\-errors] [[\fI"command"\fR...]]
.SH "DESCRIPTION"
.PP
\fBpee\fR
@@ -42,10 +42,30 @@ but for pipes\&. Each command is run and fed a copy of the standard input\&. The
Note that while this is similar to
\fBtee\fR, a copy of the input is not sent to stdout, like tee does\&. If that is desired, use
\fBpee cat \&.\&.\&.\fR
+.SH "OPTIONS"
+.PP
+\fB\-\-ignore\-sigpipe\fR, \fB\-\-no\-ignore\-sigpipe\fR
+.RS 4
+Do (not) ignore SIGPIPE\&. Any command started by
+\fBpee\fR
+might cause a SIGPIPE when it exists\&. If you ignore SIGPIPE, you probably also want to ignore write errors (see below)\&. Ignoring SIGPIPE is the default behaviour\&.
+.RE
+.PP
+\fB\-\-ignore\-write\-errors\fR, \fB\-\-no\-ignore\-write\-errors\fR
+.RS 4
+Do (not) ignore write errors\&. When a command started by
+\fBpee\fR
+is no more accepting data via the pipe between itself and
+\fBpee\fR, a write error occurs in
+\fBpee\fR\&. If this error is not ignored,
+\fBpee\fR
+is going to terminate all child processes and exists\&. Ignoring write errors is the default behaviour\&.
+.RE
.SH "SEE ALSO"
.PP
-\fBtee\fR(1)
+\fBtee\fR(1),
+\fBpipe\fR(7)
.SH "AUTHOR"
.PP
Miek Gieben