aboutsummaryrefslogtreecommitdiff
path: root/sysutils/moreutils
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-04 15:36:36 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-04 15:36:36 +0000
commit87310c79cb7560cb60a13b8c37fa9924c702263f (patch)
tree7ac56fee85f7965462ce1cc2923cae3c1971bf06 /sysutils/moreutils
parent658fd28e6f97b298b2d008da872c7cd788866f4b (diff)
downloadports-87310c79cb7560cb60a13b8c37fa9924c702263f.tar.gz
ports-87310c79cb7560cb60a13b8c37fa9924c702263f.zip
- Support STAGEDIR
Notes
Notes: svn path=/head/; revision=329327
Diffstat (limited to 'sysutils/moreutils')
-rw-r--r--sysutils/moreutils/Makefile34
-rw-r--r--sysutils/moreutils/files/patch-Makefile12
-rw-r--r--sysutils/moreutils/pkg-plist26
3 files changed, 39 insertions, 33 deletions
diff --git a/sysutils/moreutils/Makefile b/sysutils/moreutils/Makefile
index b22f9e8bb836..3dc022527070 100644
--- a/sysutils/moreutils/Makefile
+++ b/sysutils/moreutils/Makefile
@@ -16,56 +16,40 @@ RUN_DEPENDS= p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run
OPTIONS_DEFINE= MANPAGES
OPTIONS_DEFAULT=MANPAGES
+OPTIONS_SUB= yes
ALL_TARGET= bins
USES= perl5
WRKSRC= ${WRKDIR}/${PORTNAME}
-MANCOMPRESSED= no
-PLIST_FILES= bin/chronic \
- bin/combine \
- bin/errno \
- bin/ifne \
- bin/isutf8 \
- bin/lckdo \
- bin/mispipe \
- bin/pee \
- bin/sponge \
- bin/ts \
- bin/vidir \
- bin/vipe \
- bin/zrun
+MANPAGES_ALL_TARGET= mans
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMANPAGES}
-ALL_TARGET+= mans
-CANNED_MAN1= errno.1 \
+CANNED_MANPAGES=errno.1 \
ifne.1 \
isutf8.1 \
lckdo.1 \
mispipe.1 \
pee.1 \
sponge.1
-MAN1= chronic.1 \
+MANPAGES= chronic.1 \
combine.1 \
ts.1 \
vidir.1 \
vipe.1 \
zrun.1 \
- ${CANNED_MAN1}
-.endif
+ ${CANNED_MANPAGES}
+
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|share/xml/docbook/schema/dtd/|local/share/xml/docbook/|' ${WRKSRC}/*.docbook
.if ${PORT_OPTIONS:MMANPAGES}
- @cd ${FILESDIR}/ && ${CP} ${CANNED_MAN1} ${WRKSRC}/
+ @cd ${FILESDIR}/ && ${CP} ${CANNED_MANPAGES} ${WRKSRC}/
.endif
post-install:
.if ${PORT_OPTIONS:MMANPAGES}
- cd ${WRKSRC}/ && ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1/
+ cd ${WRKSRC}/ && ${INSTALL_MAN} ${MANPAGES} ${STAGEDIR}${PREFIX}/man/man1/
.endif
.include <bsd.port.mk>
diff --git a/sysutils/moreutils/files/patch-Makefile b/sysutils/moreutils/files/patch-Makefile
index 5066eb19f1f1..a1ae5b87de4f 100644
--- a/sysutils/moreutils/files/patch-Makefile
+++ b/sysutils/moreutils/files/patch-Makefile
@@ -1,6 +1,6 @@
--- Makefile.orig 2012-06-06 01:55:53.000000000 +0800
+++ Makefile 2013-02-24 13:23:52.068205829 +0800
-@@ -1,60 +1,38 @@
+@@ -1,14 +1,17 @@
-BINS=isutf8 ifdata ifne pee sponge mispipe lckdo parallel errno
+BINS=isutf8 ifne pee sponge mispipe lckdo errno
PERLSCRIPTS=vidir vipe ts combine zrun chronic
@@ -23,13 +23,9 @@
clean:
rm -f $(BINS) $(MANS) dump.c errnos.h errno.o
- install:
-- mkdir -p $(DESTDIR)$(PREFIX)/bin
-- $(INSTALL_BIN) $(BINS) $(DESTDIR)$(PREFIX)/bin
-- install $(PERLSCRIPTS) $(DESTDIR)$(PREFIX)/bin
-+ mkdir -p $(PREFIX)/bin
-+ $(INSTALL_BIN) $(BINS) $(PREFIX)/bin
-+ install $(PERLSCRIPTS) $(PREFIX)/bin
+@@ -17,44 +20,19 @@
+ $(INSTALL_BIN) $(BINS) $(DESTDIR)$(PREFIX)/bin
+ install $(PERLSCRIPTS) $(DESTDIR)$(PREFIX)/bin
- mkdir -p $(DESTDIR)$(PREFIX)/share/man/man1
- install $(MANS) $(DESTDIR)$(PREFIX)/share/man/man1
diff --git a/sysutils/moreutils/pkg-plist b/sysutils/moreutils/pkg-plist
new file mode 100644
index 000000000000..899f1660c3cd
--- /dev/null
+++ b/sysutils/moreutils/pkg-plist
@@ -0,0 +1,26 @@
+bin/chronic
+bin/combine
+bin/errno
+bin/ifne
+bin/isutf8
+bin/lckdo
+bin/mispipe
+bin/pee
+bin/sponge
+bin/ts
+bin/vidir
+bin/vipe
+bin/zrun
+%%MANPAGES%%man/man1/chronic.1.gz
+%%MANPAGES%%man/man1/combine.1.gz
+%%MANPAGES%%man/man1/errno.1.gz
+%%MANPAGES%%man/man1/ifne.1.gz
+%%MANPAGES%%man/man1/isutf8.1.gz
+%%MANPAGES%%man/man1/lckdo.1.gz
+%%MANPAGES%%man/man1/mispipe.1.gz
+%%MANPAGES%%man/man1/pee.1.gz
+%%MANPAGES%%man/man1/sponge.1.gz
+%%MANPAGES%%man/man1/ts.1.gz
+%%MANPAGES%%man/man1/vidir.1.gz
+%%MANPAGES%%man/man1/vipe.1.gz
+%%MANPAGES%%man/man1/zrun.1.gz