aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mountsmb2
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2006-04-30 14:41:30 +0000
committerAndrey Slusar <anray@FreeBSD.org>2006-04-30 14:41:30 +0000
commit1bccabdb11f8cf46c56ecdc3927e721e0e7c8ea1 (patch)
treeaf659efc5c0d126222ad294f63638723abe5d947 /sysutils/mountsmb2
parent2c70966e8e5a53bfbccbe59ff5ec948e9e6f4005 (diff)
downloadports-1bccabdb11f8cf46c56ecdc3927e721e0e7c8ea1.tar.gz
ports-1bccabdb11f8cf46c56ecdc3927e721e0e7c8ea1.zip
Add mountsmb2 0.90.1, SMB/CIFS shares mounting scripts to do it at
login. PR: ports/94601 Submitted by: Rashid N. Achilov <shelton@www.granch.ru>
Notes
Notes: svn path=/head/; revision=160910
Diffstat (limited to 'sysutils/mountsmb2')
-rw-r--r--sysutils/mountsmb2/Makefile41
-rw-r--r--sysutils/mountsmb2/distinfo3
-rw-r--r--sysutils/mountsmb2/pkg-descr11
-rw-r--r--sysutils/mountsmb2/pkg-message22
-rw-r--r--sysutils/mountsmb2/pkg-plist10
5 files changed, 87 insertions, 0 deletions
diff --git a/sysutils/mountsmb2/Makefile b/sysutils/mountsmb2/Makefile
new file mode 100644
index 000000000000..c73bb645ee63
--- /dev/null
+++ b/sysutils/mountsmb2/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: mountsmb2
+# Date created: 17 Mar 2006
+# Whom: Rashid N. Achilov <shelton@granch.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mountsmb2
+PORTVERSION= 0.90.1
+CATEGORIES= sysutils net
+MASTER_SITES= ftp://ftp.granch.ru/pub/other/
+
+MAINTAINER= shelton@www.granch.ru
+COMMENT= SMB/CIFS shares mounting scripts to do it at login
+
+RUN_DEPENDS= findsmb:${PORTSDIR}/net/samba3 \
+ sudo:${PORTSDIR}/security/sudo \
+ gawk:${PORTSDIR}/lang/gawk
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+do-install:
+
+.for i in smb2awk smb2nsmbrc mountsmb2
+ ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOCS)
+ -@${MKDIR} ${EXAMPLESDIR}
+
+.for i in sudoers .login .nsmbrc .mssmbrc
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${EXAMPLESDIR}
+.endfor
+
+ -@${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.FreeBSD ${DOCSDIR}
+
+ @${SED} -e "s,%%EXAMPLESDIR%%,${EXAMPLESDIR},g" ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/mountsmb2/distinfo b/sysutils/mountsmb2/distinfo
new file mode 100644
index 000000000000..3ab712823dda
--- /dev/null
+++ b/sysutils/mountsmb2/distinfo
@@ -0,0 +1,3 @@
+MD5 (mountsmb2-0.90.1.tar.bz2) = 7312cf69995b148dfd03a845805a58b7
+SHA256 (mountsmb2-0.90.1.tar.bz2) = 5efae56f0d38b3964cff38960f1b855b62210d8332ddeffe5e9ae209bbf06ee7
+SIZE (mountsmb2-0.90.1.tar.bz2) = 5505
diff --git a/sysutils/mountsmb2/pkg-descr b/sysutils/mountsmb2/pkg-descr
new file mode 100644
index 000000000000..f5500600d682
--- /dev/null
+++ b/sysutils/mountsmb2/pkg-descr
@@ -0,0 +1,11 @@
+This set of scripts allows you to imitate Windows feature to automount some
+network shares at login time. It is relatively difficult in setup - you should
+understand, what you do, know how to install SMB/CIFS support into a kernel,
+how to setup /etc/nsmb.conf and .nsmbrc files, etc.
+
+Script are written on Shell. Uses Samba utility findsmb to locate Windows boxes
+when generated .nsmbrc file in semi-automated mode with smb2nsmbrc helper
+script. Also uses their own file .mssmbrc to describe any share, mounted with
+mountsmb2.
+
+WWW: http://www.granch.ru/~shelton
diff --git a/sysutils/mountsmb2/pkg-message b/sysutils/mountsmb2/pkg-message
new file mode 100644
index 000000000000..b7720dddcd5c
--- /dev/null
+++ b/sysutils/mountsmb2/pkg-message
@@ -0,0 +1,22 @@
+***********************************************************
+
+Please, read %%EXAMPLESDIR%%/README.FreeBSD
+*B*E*F*O*R*E* the FIRST RUN of Mountsmb2!
+
+In order to run Mountsmb2 properly, be sure that:
+
+1. Your kernel is configured properly
+2. Your /etc/nsmb.conf file is configured properly
+3. Your .nsmbrc file is configured properly (this means, that
+ the password to *ANY* server in your network is recorded in
+ this file. For semi-automatic creation of .nsmbrc you can use
+ the smb2nsmbrc script)
+4. Your .mssmbrc file is created and filled properly
+
+Keep in mind, that:
+
+1. Mountsmb2 only calls mount_smbfs to mount shares with params, described in
+ a .mssmbrc file
+2. DO NOT DISTURB ME ABOUT FreeBSD's SMB IMPLEMENTATION!
+
+************************************************************
diff --git a/sysutils/mountsmb2/pkg-plist b/sysutils/mountsmb2/pkg-plist
new file mode 100644
index 000000000000..6953d32164ea
--- /dev/null
+++ b/sysutils/mountsmb2/pkg-plist
@@ -0,0 +1,10 @@
+bin/mountsmb2
+bin/smb2nsmbrc
+bin/smb2awk
+%%PORTDOCS%%%%EXAMPLESDIR%%/sudoers
+%%PORTDOCS%%%%EXAMPLESDIR%%/.login
+%%PORTDOCS%%%%EXAMPLESDIR%%/.nsmbrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/.mssmbrc
+%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%