aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nitrogen
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /sysutils/nitrogen
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=366215
Diffstat (limited to 'sysutils/nitrogen')
-rw-r--r--sysutils/nitrogen/Makefile21
1 files changed, 4 insertions, 17 deletions
diff --git a/sysutils/nitrogen/Makefile b/sysutils/nitrogen/Makefile
index ac2e49444b40..cb111f0f1ca4 100644
--- a/sysutils/nitrogen/Makefile
+++ b/sysutils/nitrogen/Makefile
@@ -13,19 +13,6 @@ COMMENT= Background browser and setter for X windows
LICENSE= GPLv2 # (or later)
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS= libatkmm-1.6.so:${PORTSDIR}/accessibility/atkmm \
- libglibmm-2.4.so:${PORTSDIR}/devel/glibmm \
- libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
- libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
- libpcre.so:${PORTSDIR}/devel/pcre \
- libcairo.so:${PORTSDIR}/graphics/cairo \
- libcairomm-1.0.so:${PORTSDIR}/graphics/cairomm \
- libpng15.so:${PORTSDIR}/graphics/png \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libexpat.so:${PORTSDIR}/textproc/expat2 \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
- libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24 \
- libpangomm-1.4.so:${PORTSDIR}/x11-toolkits/pangomm
RUN_DEPENDS= gnome-icon-theme>0:${PORTSDIR}/misc/gnome-icon-theme \
hicolor-icon-theme>0:${PORTSDIR}/misc/hicolor-icon-theme
@@ -33,15 +20,14 @@ OPTIONS_DEFINE= XINERAMA
OPTIONS_DEFAULT=XINERAMA
USES= gettext iconv pkgconfig
-USE_GNOME= gtk20
-USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext xfixes \
- xrandr xrender
+USE_GNOME= gtkmm24
+USE_XORG= x11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-inotify
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lX11
DESKTOP_ENTRIES="Nitrogen" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" \
"Graphics;Viewer;" true
@@ -58,5 +44,6 @@ CONFIGURE_ARGS+=--disable-xinerama
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/data/icon-theme-installer
+ @${REINPLACE_CMD} '/^LIBS =/s/$$/ @LIBS@/' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>