aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nomad
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2019-09-29 22:34:31 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2019-09-29 22:34:31 +0000
commitfc95b3f0cf943e760e906eac92aac51eff4d0c1c (patch)
tree8b41993e1df35d7245f4013a2d3adcb758a276a1 /sysutils/nomad
parent67c4b925b7fd606361a2152563b80da493232dfb (diff)
downloadports-fc95b3f0cf943e760e906eac92aac51eff4d0c1c.tar.gz
ports-fc95b3f0cf943e760e906eac92aac51eff4d0c1c.zip
Notes
Diffstat (limited to 'sysutils/nomad')
-rw-r--r--sysutils/nomad/Makefile27
1 files changed, 8 insertions, 19 deletions
diff --git a/sysutils/nomad/Makefile b/sysutils/nomad/Makefile
index e41db13d6a39..f0fa28d14136 100644
--- a/sysutils/nomad/Makefile
+++ b/sysutils/nomad/Makefile
@@ -14,32 +14,21 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= On i386: go compiler crashes: https://github.com/golang/go/issues/23763
-USES= compiler go
+USES= go
USE_GITHUB= yes
GH_ACCOUNT= hashicorp
GH_SUBDIR= src/github.com/hashicorp/nomad
USE_RC_SUBR= nomad
+GO_BUILDFLAGS= -tags ui \
+ -ldflags "-X main.GitDescribe=${DISTVERSIONFULL}"
+
USERS= nomad
GROUPS= nomad
-do-build:
- @cd ${WRKSRC}/src/github.com/hashicorp/nomad && \
- ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -v -x -tags ui \
- -ldflags "-X main.GitDescribe=${DISTVERSIONFULL}" -o bin/nomad
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/hashicorp/nomad/bin/nomad ${STAGEDIR}${PREFIX}/bin/nomad
+post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/nomad
- ${INSTALL_DATA} ${WRKSRC}/src/github.com/hashicorp/nomad/dist/client.hcl \
- ${STAGEDIR}${PREFIX}/etc/nomad/client.hcl.sample
- ${INSTALL_DATA} ${WRKSRC}/src/github.com/hashicorp/nomad/dist/server.hcl \
- ${STAGEDIR}${PREFIX}/etc/nomad/server.hcl.sample
-
-.include <bsd.port.pre.mk>
-
-.if ${COMPILER_TYPE} == clang
-BUILD_ENV= CC=clang
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/dist/client.hcl ${STAGEDIR}${PREFIX}/etc/nomad/client.hcl.sample
+ ${INSTALL_DATA} ${WRKSRC}/dist/server.hcl ${STAGEDIR}${PREFIX}/etc/nomad/server.hcl.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>