aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nss_ndb
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2020-06-13 20:34:55 +0000
committerKurt Jaeger <pi@FreeBSD.org>2020-06-13 20:34:55 +0000
commit9d6ad92365a6ff5ac264eb5ee0f1754834564186 (patch)
tree0757cb9856380575d9f3db6126d6d54b8644e293 /sysutils/nss_ndb
parent0361443876265f60983b3aa5b5d2c9ae9479bea3 (diff)
downloadports-9d6ad92365a6ff5ac264eb5ee0f1754834564186.tar.gz
ports-9d6ad92365a6ff5ac264eb5ee0f1754834564186.zip
New port: sysutils/nss_ndb BerkeleyDB-based nsswitch backend for passwd & groups
This project consists of a NSS module (nss_ndb.so.1) and a CLI utility (makendb) that enables big passwd & group files to be handled efficiently via BTree BerkeleyDB databases. To activate and use this you must (after installation): 1. Manually add a symbolic link: /usr/lib/nss_ndb.so.1 -> /path/to/lib/nss_ndb.so.1.<version> 2. Populate the databases in /var/db/nss_ndb via "makendb" (or some other tool). 3. Activate it in /etc/nsswitch.conf: passwd: files ndb group: files ndb WWW: https://github.com/ptrrkssn/nss_ndb PR: 247211 Submitted by: Peter Eriksson <pen@lysator.liu.se>
Notes
Notes: svn path=/head/; revision=538698
Diffstat (limited to 'sysutils/nss_ndb')
-rw-r--r--sysutils/nss_ndb/Makefile69
-rw-r--r--sysutils/nss_ndb/distinfo3
-rw-r--r--sysutils/nss_ndb/pkg-descr22
3 files changed, 94 insertions, 0 deletions
diff --git a/sysutils/nss_ndb/Makefile b/sysutils/nss_ndb/Makefile
new file mode 100644
index 000000000000..6e2fb8e85d58
--- /dev/null
+++ b/sysutils/nss_ndb/Makefile
@@ -0,0 +1,69 @@
+# $FreeBSD$
+
+PORTNAME= nss_ndb
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.23
+CATEGORIES= sysutils security
+
+MAINTAINER= pen@lysator.liu.se
+COMMENT= BerkeleyDB-based nsswitch backend for passwd & groups
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+OPTIONS_DEFINE= CFG VAR REALM WRKGRP
+
+CFG_DESC= Enable configuration file
+CFG_CONFIGURE_ON= --with-config-file
+CFG_PLIST_FILES+= etc/nss_ndb.conf
+
+VAR_DESC= Enable configuration variable
+VAR_CONFIGURE_ON= --with-config-var
+
+REALM_DESC= Enable realm stripping
+REALM_CONFIGURE_ON= --with-realm
+
+WRKGRP_DESC= Enable workgroup stripping
+WRKGRP_CONFIGURE_ON= --with-workgroup
+
+OPTIONS_SINGLE= BDB
+OPTIONS_SINGLE_BDB= DB0 DB6 DB5 DB4
+OPTIONS_DEFAULT= DB0
+
+DB0_DESC= Use old libc version of Berkeley DB
+DB0_CONFIGURE_ON= --without-db
+
+DB6_DESC= Build with Berkeley DB v6 library
+DB6_USES+= localbase
+DB6_USE_LDCONFIG+= yes
+DB6_LIB_DEPENDS= libdb-6.so:databases/db6
+DB6_CONFIGURE_ON= --with-db=6
+
+DB5_DESC= Build with Berkeley DB v5 library
+DB5_USES+= localbase
+DB5_USE_LDCONFIG+= yes
+DB5_LIB_DEPENDS= libdb-5.so:databases/db5
+DB5_CONFIGURE_ON= --with-db=5
+
+DB4_DESC= Build with Berkeley DB v4.8 library
+DB4_USES+= localbase
+DB4_USE_LDCONFIG+= yes
+DB4_LIB_DEPENDS= libdb-4.8.so:databases/db48
+DB4_CONFIGURE_ON= --with-db=4
+
+USE_GITHUB= yes
+GH_ACCOUNT= ptrrkssn
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= lib/nss_ndb.so.1 \
+ lib/nss_ndb.so.1.0.23 \
+ sbin/makendb sbin/nsstest \
+ man/man5/nss_ndb.conf.5.gz \
+ man/man8/makendb.8.gz \
+ man/man8/nsstest.8.gz \
+ man/man8/nss_ndb.8.gz \
+ share/examples/nss_ndb/ndbsync \
+ share/examples/nss_ndb/nss_ndb.conf \
+
+.include <bsd.port.mk>
diff --git a/sysutils/nss_ndb/distinfo b/sysutils/nss_ndb/distinfo
new file mode 100644
index 000000000000..a8631fb00b54
--- /dev/null
+++ b/sysutils/nss_ndb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1592076403
+SHA256 (ptrrkssn-nss_ndb-v1.0.23_GH0.tar.gz) = b629c551f21bd5ddc33177afb856cf48824767e37a3b7b63961baf57d5f00a5a
+SIZE (ptrrkssn-nss_ndb-v1.0.23_GH0.tar.gz) = 89677
diff --git a/sysutils/nss_ndb/pkg-descr b/sysutils/nss_ndb/pkg-descr
new file mode 100644
index 000000000000..12adce4e5787
--- /dev/null
+++ b/sysutils/nss_ndb/pkg-descr
@@ -0,0 +1,22 @@
+This project consists of a NSS module (nss_ndb.so.1) and a CLI
+utility (makendb) that enables big passwd & group files to be
+handled efficiently via BTree BerkeleyDB databases.
+
+To activate and use this you must (after installation):
+
+1. Manually add a symbolic link:
+
+ /usr/lib/nss_ndb.so.1 -> /path/to/lib/nss_ndb.so.1.<version>
+
+2. Populate the databases in /var/db/nss_ndb via "makendb" (or some
+ other tool).
+
+3. Activate it in /etc/nsswitch.conf:
+
+ passwd: files ndb
+ group: files ndb
+
+WWW: https://github.com/ptrrkssn/nss_ndb
+
+- Peter Eriksson
+pen@lysator.liu.se