aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nut-devel
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2020-03-29 17:37:39 +0000
committerCy Schubert <cy@FreeBSD.org>2020-03-29 17:37:39 +0000
commit7affde6c1b29f408b44e47ad1f27afa63fabb26d (patch)
tree42fff9c0e5e73d354f78fb4130a414a3b10e3da9 /sysutils/nut-devel
parenta3df16382b01d4017693dd58366c5aaf57b08e4f (diff)
downloadports-7affde6c1b29f408b44e47ad1f27afa63fabb26d.tar.gz
ports-7affde6c1b29f408b44e47ad1f27afa63fabb26d.zip
Fix build issues:
- python is invoked directly by various scripts within WRKSRC. - build man pages and documentation. Reported by: dutchman01 at quicknet.nl
Notes
Notes: svn path=/head/; revision=529818
Diffstat (limited to 'sysutils/nut-devel')
-rw-r--r--sysutils/nut-devel/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/sysutils/nut-devel/Makefile b/sysutils/nut-devel/Makefile
index f5976abc346b..e2e986ac3dd0 100644
--- a/sysutils/nut-devel/Makefile
+++ b/sysutils/nut-devel/Makefile
@@ -68,6 +68,8 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
--with-group=${NUT_GROUP} \
--with-dev
+BUILD_DEPENDS= asciidoc:textproc/asciidoc
+
.if ${PORT_OPTIONS:MCGI}
LIB_DEPENDS+= libgd.so:graphics/gd
CGIDIR?= ${PREFIX}/www/cgi-bin/${PORTNAME}
@@ -174,6 +176,10 @@ CONFIGURE_ARGS+= --with-nss
CONFIGURE_ARGS+= --without-openssl --without-ssl
.endif
+post-patch:
+ @${REINPLACE_CMD} -i '' -e 's|python|${PYTHON_CMD}|' ${WRKSRC}/autogen.sh
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -i '' -e 's|/usr/bin/env python|${PYTHON_CMD}|'
+
pre-configure:
cd ${WRKSRC} && ./autogen.sh