aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nut
diff options
context:
space:
mode:
authorBoris Popov <bp@FreeBSD.org>2000-01-11 11:55:48 +0000
committerBoris Popov <bp@FreeBSD.org>2000-01-11 11:55:48 +0000
commite905d01c4cca2e8599596fa432a05589ff262f48 (patch)
tree77429d886fa1e081cfb9b55b0a443bfbd83ebf57 /sysutils/nut
parent6a5959062e7bfd02fedbcfaf32adc71cc80f5b93 (diff)
downloadports-e905d01c4cca2e8599596fa432a05589ff262f48.tar.gz
ports-e905d01c4cca2e8599596fa432a05589ff262f48.zip
Notes
Diffstat (limited to 'sysutils/nut')
-rw-r--r--sysutils/nut/Makefile64
-rw-r--r--sysutils/nut/distinfo1
-rw-r--r--sysutils/nut/files/patch-aa54
-rw-r--r--sysutils/nut/pkg-comment1
-rw-r--r--sysutils/nut/pkg-descr7
-rw-r--r--sysutils/nut/pkg-plist17
-rw-r--r--sysutils/nut/pkg-plist.cgi6
-rw-r--r--sysutils/nut/pkg-plist.doc14
8 files changed, 164 insertions, 0 deletions
diff --git a/sysutils/nut/Makefile b/sysutils/nut/Makefile
new file mode 100644
index 000000000000..55b81bdf9fba
--- /dev/null
+++ b/sysutils/nut/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: nut
+# Version required: nut-0.42.1
+# Date created: 08 Jan 2000
+# Whom: Boris Popov <bp@freebsd.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= nut-0.42.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.exploits.org/nut/release/
+
+MAINTAINER= bp@butya.kz
+
+.if defined(CGI)
+LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-celsius --sysconfdir=${PREFIX}/etc/nut \
+ --with-uid=65534 --with-gid=68
+ALL_TARGET= all
+
+PLIST= ${WRKDIR}/PLIST.DYN
+
+NDOCDIR= ${PREFIX}/share/doc/nut
+
+.if defined(CGI)
+NCGIDIR= ${PREFIX}/share/nut/cgi
+ALL_TARGET+= cgi
+.endif
+
+pre-fetch:
+.if !defined(CGI)
+ @${ECHO_MSG} "Type \"make CGI=yes\" if you want to build CGI scripts."
+.endif
+
+pre-install:
+ @cp ${PKGDIR}/PLIST ${WRKDIR}/PLIST.DYN
+.if !defined(NOPORSDOCS)
+ @cat ${PKGDIR}/PLIST.DOC >> ${WRKDIR}/PLIST.DYN
+.endif
+.if defined(CGI)
+ @cat ${PKGDIR}/PLIST.CGI >> ${WRKDIR}/PLIST.DYN
+.endif
+
+post-install:
+ @${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/upsd.sh.sample \
+ >${PREFIX}/etc/rc.d/upsd.sh.sample
+ @${CHMOD} 0755 ${PREFIX}/etc/rc.d/upsd.sh.sample
+.if !defined(NOPORTDOCS)
+ @if ! [ -d ${NDOCDIR} ]; then ${MKDIR} ${NDOCDIR}; fi
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${NDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${NDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/QUICKSTART ${NDOCDIR}
+.endif
+.if defined(CGI)
+ @if ! [ -d ${NCGIDIR} ]; then ${MKDIR} ${NCGIDIR}; fi
+ ${INSTALL_DATA} ${WRKSRC}/clients/*.cgi ${NCGIDIR}
+ @${ECHO_MSG} "Look in ${NCGIDIR} for cgi scripts."
+.endif
+ @${ECHO_MSG} "Look in ${NDOCDIR} for documentation."
+
+.include <bsd.port.mk>
diff --git a/sysutils/nut/distinfo b/sysutils/nut/distinfo
new file mode 100644
index 000000000000..88c3d4257310
--- /dev/null
+++ b/sysutils/nut/distinfo
@@ -0,0 +1 @@
+MD5 (nut-0.42.1.tar.gz) = 56edd3af2de100680962585a1bd02bbc
diff --git a/sysutils/nut/files/patch-aa b/sysutils/nut/files/patch-aa
new file mode 100644
index 000000000000..043bed9cc5bf
--- /dev/null
+++ b/sysutils/nut/files/patch-aa
@@ -0,0 +1,54 @@
+--- clients/Makefile.in.org Wed Nov 10 01:36:44 1999
++++ clients/Makefile.in Mon Jan 10 16:43:44 2000
+@@ -53,8 +53,8 @@
+
+ install: all
+ @for p in $(PROGS) ; do \
+- echo cp $$p $(BASEPATH)/bin; \
+- cp $$p $(BASEPATH)/bin; \
++ echo cp $$p $(BASEPATH)/sbin; \
++ cp $$p $(BASEPATH)/sbin; \
+ done
+
+ install-cgi: cgi
+
+--- conf/Makefile.in.org Mon Oct 18 03:56:11 1999
++++ conf/Makefile.in Tue Jan 11 16:57:15 2000
+@@ -9,10 +9,6 @@
+
+ install:
+ @for f in $(CONFFILES) ; do \
+- if [ -f $(CONFPATH)/$$f ]; then \
+- echo "Preserving existing config file: $$f"; \
+- else \
+- echo cp $$f $(CONFPATH); \
+- cp $$f $(CONFPATH); \
+- fi; \
++ echo cp $$f $(CONFPATH)/$$f.sample; \
++ cp $$f $(CONFPATH)/$$f.sample; \
+ done
+
+--- server/Makefile.in.org Wed Nov 10 01:37:01 1999
++++ server/Makefile.in Mon Jan 10 16:41:55 2000
+@@ -21,6 +21,6 @@
+
+ install: all
+ @for p in $(PROGS) ; do \
+- echo cp $$p $(BASEPATH)/bin ; \
+- cp $$p $(BASEPATH)/bin; \
++ echo cp $$p $(BASEPATH)/sbin ; \
++ cp $$p $(BASEPATH)/sbin; \
+ done
+
+--- models/Makefile.in.org Wed Nov 10 01:36:44 1999
++++ models/Makefile.in Mon Jan 10 16:43:44 2000
+@@ -35,6 +35,6 @@
+
+ install: all
+ @for p in $(PROGS) ; do \
+- echo cp $$p $(BASEPATH)/bin; \
+- cp $$p $(BASEPATH)/bin; \
++ echo cp $$p $(BASEPATH)/sbin; \
++ cp $$p $(BASEPATH)/sbin; \
+ done
+
diff --git a/sysutils/nut/pkg-comment b/sysutils/nut/pkg-comment
new file mode 100644
index 000000000000..83ab91a03e2d
--- /dev/null
+++ b/sysutils/nut/pkg-comment
@@ -0,0 +1 @@
+Network UPS Tools
diff --git a/sysutils/nut/pkg-descr b/sysutils/nut/pkg-descr
new file mode 100644
index 000000000000..cfc898ce8095
--- /dev/null
+++ b/sysutils/nut/pkg-descr
@@ -0,0 +1,7 @@
+This is a developing project to monitor a large assortment of UPS hardware.
+Network communications are used so that multiple systems can monitor a
+single physical UPS and shut down together if necessary without any
+special "sharing hardware" on the UPS itself. CGI scripts provided
+to monitor UPS status via WEB browser.
+
+WWW: http://www.exploits.org/nut/
diff --git a/sysutils/nut/pkg-plist b/sysutils/nut/pkg-plist
new file mode 100644
index 000000000000..a084e0afe08a
--- /dev/null
+++ b/sysutils/nut/pkg-plist
@@ -0,0 +1,17 @@
+sbin/apcsmart
+sbin/genericups
+sbin/optiups
+sbin/bestups
+sbin/ups-trust425+625
+sbin/fentonups
+sbin/upsc
+sbin/upslog
+sbin/upsmon
+sbin/upsct
+sbin/upsct2
+sbin/upsd
+etc/nut/hosts.conf.sample
+etc/nut/multimon.conf.sample
+etc/nut/upsd.conf.sample
+etc/nut/upsmon.conf.sample
+etc/rc.d/upsd.sh.sample
diff --git a/sysutils/nut/pkg-plist.cgi b/sysutils/nut/pkg-plist.cgi
new file mode 100644
index 000000000000..670b38eca27c
--- /dev/null
+++ b/sysutils/nut/pkg-plist.cgi
@@ -0,0 +1,6 @@
+share/nut/cgi/multimon.cgi
+share/nut/cgi/upsimage.cgi
+share/nut/cgi/upsset.cgi
+share/nut/cgi/upsstats.cgi
+@dirrm share/nut/cgi
+@dirrm share/nut
diff --git a/sysutils/nut/pkg-plist.doc b/sysutils/nut/pkg-plist.doc
new file mode 100644
index 000000000000..7c904e08fa3c
--- /dev/null
+++ b/sysutils/nut/pkg-plist.doc
@@ -0,0 +1,14 @@
+share/doc/nut/FAQ
+share/doc/nut/access.txt
+share/doc/nut/commands.txt
+share/doc/nut/generic-ups.txt
+share/doc/nut/new-modules.txt
+share/doc/nut/pager.txt
+share/doc/nut/protocol.txt
+share/doc/nut/shutdown.txt
+share/doc/nut/tips.txt
+share/doc/nut/todo.txt
+share/doc/nut/ups-trust425+625.txt
+share/doc/nut/README
+share/doc/nut/QUICKSTART
+@dirrm share/doc/nut