aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nvme-cli
diff options
context:
space:
mode:
authorWarner Losh <imp@FreeBSD.org>2018-10-14 05:34:43 +0000
committerWarner Losh <imp@FreeBSD.org>2018-10-14 05:34:43 +0000
commit9551e869aada768a7f17a38cf919c51cf52df703 (patch)
tree1665375eeb54ac53298a30dae50d3fac57f92f57 /sysutils/nvme-cli
parenta264cb5ec10be8cb457cda3d823b7bfaad1b2d20 (diff)
downloadports-9551e869aada768a7f17a38cf919c51cf52df703.tar.gz
ports-9551e869aada768a7f17a38cf919c51cf52df703.zip
Add new port for Linux-nvme's nvme-cli program.
The nvme program allows sending of arbitrary commands to nvme devices. Only the admin-passthru command is known to work, though others might. Many linuxisms remain in this program that, though it compiles, will likely not work on FreeBSD, preventing other commands from working. Marked only for amd64 / FreeBSD 12/13 since it's only been tested there and uses APIs that are unstable between the major releases. Upstreamable patches welcome to fix any of this, and this port will evolve as my patches get accepted upstream.
Notes
Notes: svn path=/head/; revision=482025
Diffstat (limited to 'sysutils/nvme-cli')
-rw-r--r--sysutils/nvme-cli/Makefile26
-rw-r--r--sysutils/nvme-cli/distinfo3
-rw-r--r--sysutils/nvme-cli/pkg-descr3
3 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/nvme-cli/Makefile b/sysutils/nvme-cli/Makefile
new file mode 100644
index 000000000000..517e8b492347
--- /dev/null
+++ b/sysutils/nvme-cli/Makefile
@@ -0,0 +1,26 @@
+# Created by: imp
+# $FreeBSD$
+
+PORTNAME= nvme-cli
+PORTVERSION= 1.6
+CATEGORIES= sysutils
+
+MAINTAINER= imp@FreeBSD.org
+COMMENT= Port of Linux nvme cli utility
+
+LICENSE= GPLv2
+
+# only tested on amd64, all other archs are no-go until we're sure amd64 works.
+# And there's plenty in amd64 that compiles, but won't run (eg using /sys/, etc)
+ONLY_FOR_ARCHS= amd64
+BROKEN_FreeBSD_11= Uses newer API than in 11.x
+BROKEN_FreeBSD_10= Uses newer API than in 10.x
+
+USES= gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= bsdimp
+GH_PROJECT= nvme-cli
+GH_TAGNAME= 9221b5f
+
+.include <bsd.port.mk>
diff --git a/sysutils/nvme-cli/distinfo b/sysutils/nvme-cli/distinfo
new file mode 100644
index 000000000000..95602456b1ef
--- /dev/null
+++ b/sysutils/nvme-cli/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539492927
+SHA256 (bsdimp-nvme-cli-1.6-9221b5f_GH0.tar.gz) = b0b0c69f1315f332235a509dee509b98e0f01dccff5642351c0e88db252c821e
+SIZE (bsdimp-nvme-cli-1.6-9221b5f_GH0.tar.gz) = 379619
diff --git a/sysutils/nvme-cli/pkg-descr b/sysutils/nvme-cli/pkg-descr
new file mode 100644
index 000000000000..c81e697f701f
--- /dev/null
+++ b/sysutils/nvme-cli/pkg-descr
@@ -0,0 +1,3 @@
+NVM-Express user space tooling for Linux.
+
+WWW: https://github.com/linux-nvme/nvme-cli