aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nvramtool
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-03-18 05:06:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-03-18 05:06:07 +0000
commit20672d9f5aae3a03f202e38eb95c77209497de75 (patch)
tree46b7a803e5e075df62af021cd5a8ad553d17605d /sysutils/nvramtool
parent47b1472b7021a90739c507b9e28ae207e38c2ee0 (diff)
downloadports-20672d9f5aae3a03f202e38eb95c77209497de75.tar.gz
ports-20672d9f5aae3a03f202e38eb95c77209497de75.zip
nvramtool is a utility for reading/writing coreboot parameters and
displaying information from the coreboot table. It is intended for x86-based systems (both 32-bit and 64-bit) that use coreboot. The coreboot table resides in low physical memory, and may be accessed through the /dev/mem interface. It is created at boot time by coreboot, and contains various system information such as the type of mainboard in use. It specifies locations in the CMOS (nonvolatile RAM) where the coreboot parameters are stored. For information about coreboot, see http://www.coreboot.org/. WWW: http://www.coreboot.org/Nvramtool PR: ports/155583 Submitted by: Andrey Zonov <andrey at zonov.org>
Notes
Notes: svn path=/head/; revision=271222
Diffstat (limited to 'sysutils/nvramtool')
-rw-r--r--sysutils/nvramtool/Makefile30
-rw-r--r--sysutils/nvramtool/distinfo2
-rw-r--r--sysutils/nvramtool/pkg-descr13
3 files changed, 45 insertions, 0 deletions
diff --git a/sysutils/nvramtool/Makefile b/sysutils/nvramtool/Makefile
new file mode 100644
index 000000000000..b71077bfa690
--- /dev/null
+++ b/sysutils/nvramtool/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: nvramtool
+# Date created: 13 Mar 2011
+# Whom: Andrey Zonov <andrey@zonov.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nvramtool
+PORTVERSION= r6440
+CATEGORIES= sysutils
+MASTER_SITES= http://www.zonov.org/${PORTNAME}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= andrey@zonov.org
+COMMENT= A utility for reading, writing the contents of CMOS memory
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+ONLY_FOR_ARCHS= amd64 i386
+
+PLIST_FILES= bin/${PORTNAME}
+
+MAN8= ${PORTNAME}.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/cli/${MAN8} ${MANPREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/sysutils/nvramtool/distinfo b/sysutils/nvramtool/distinfo
new file mode 100644
index 000000000000..58d412fd972e
--- /dev/null
+++ b/sysutils/nvramtool/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nvramtool-r6440.tar.bz2) = f66a80e458f29979cea67e6dacd62fd16c3e8e0d65bc1a52cd3f6941fbcb1f93
+SIZE (nvramtool-r6440.tar.bz2) = 43461
diff --git a/sysutils/nvramtool/pkg-descr b/sysutils/nvramtool/pkg-descr
new file mode 100644
index 000000000000..173d9bb953f6
--- /dev/null
+++ b/sysutils/nvramtool/pkg-descr
@@ -0,0 +1,13 @@
+nvramtool is a utility for reading/writing coreboot parameters and
+displaying information from the coreboot table. It is intended for x86-based
+systems (both 32-bit and 64-bit) that use coreboot.
+
+The coreboot table resides in low physical memory, and may be accessed
+through the /dev/mem interface. It is created at boot time by coreboot, and
+contains various system information such as the type of mainboard in use. It
+specifies locations in the CMOS (nonvolatile RAM) where the coreboot
+parameters are stored.
+
+For information about coreboot, see http://www.coreboot.org/.
+
+WWW: http://www.coreboot.org/Nvramtool