aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ods2
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-02-08 04:21:29 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-02-08 04:21:29 +0000
commit4e912c31ddb66063b85b44399c0d764413048ec9 (patch)
tree94b316d4ccbbf5fe26e23afbaa08f7c3e0da467a /sysutils/ods2
parent66faa415436f0487100845487f10267633d41535 (diff)
downloadports-4e912c31ddb66063b85b44399c0d764413048ec9.tar.gz
ports-4e912c31ddb66063b85b44399c0d764413048ec9.zip
Notes
Diffstat (limited to 'sysutils/ods2')
-rw-r--r--sysutils/ods2/Makefile36
-rw-r--r--sysutils/ods2/distinfo3
-rw-r--r--sysutils/ods2/files/patch-ods2.c15
-rw-r--r--sysutils/ods2/pkg-descr15
4 files changed, 69 insertions, 0 deletions
diff --git a/sysutils/ods2/Makefile b/sysutils/ods2/Makefile
new file mode 100644
index 000000000000..4b820c6c7633
--- /dev/null
+++ b/sysutils/ods2/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ods2
+# Date created: 31 January 2006
+# Whom: Thierry Dussuet <dussuett@wigwam.ethz.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ods2
+PORTVERSION= 1.3
+CATEGORIES= sysutils
+MASTER_SITES= http://www.lugs.ch/~dussuett/
+DISTNAME= ods2
+
+MAINTAINER= dussuett@wigwam.ethz.ch
+COMMENT= An utility for manipulating ODS-2 filesystems
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+MAKEFILE= makefile.unix
+MAKE_ARGS= CCFLAGS="${CFLAGS}"
+
+PLIST_FILES= sbin/ods2
+PORTDOCS= aareadme.too aareadme.txt
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|cc |${CC} |; /-oods2/ s|vmstime\.o|& -lcompat|' \
+ ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ods2 ${PREFIX}/sbin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/ods2/distinfo b/sysutils/ods2/distinfo
new file mode 100644
index 000000000000..c6c8526d1d43
--- /dev/null
+++ b/sysutils/ods2/distinfo
@@ -0,0 +1,3 @@
+MD5 (ods2.zip) = 722ea8fda67a8fd2e5fe237584951dda
+SHA256 (ods2.zip) = 6c4f0bba11958e84278dca2c78c33349575df145584c1d030a2172c7792ca7fc
+SIZE (ods2.zip) = 480695
diff --git a/sysutils/ods2/files/patch-ods2.c b/sysutils/ods2/files/patch-ods2.c
new file mode 100644
index 000000000000..29c0585be936
--- /dev/null
+++ b/sysutils/ods2/files/patch-ods2.c
@@ -0,0 +1,15 @@
+--- ods2.c~ Fri Sep 7 23:17:04 2001
++++ ods2.c Tue Jan 31 13:03:50 2006
+@@ -1094,8 +1094,10 @@
+ #ifdef VMS
+ if (getcmd (str, "$> ") == NULL) break;
+ #else
+- printf("$> ");
+- if (gets(str) == NULL) break;
++ printf("$> ");
++ if (fgets(str, sizeof(str), stdin) == NULL)
++ break;
++ str[strlen(str)-1] = '\0'; /* strip newline from str */
+ #endif
+ }
+ ptr = str;
diff --git a/sysutils/ods2/pkg-descr b/sysutils/ods2/pkg-descr
new file mode 100644
index 000000000000..cd3499d33606
--- /dev/null
+++ b/sysutils/ods2/pkg-descr
@@ -0,0 +1,15 @@
+From aaareadme.txt:
+
+Say, what is this?
+ ODS2 is a program to read VMS disk volumes written in VMS
+ ODS2 format.
+
+What can it do?
+ Basically ODS2 provides cut down DIRECTORY, COPY and
+ SEARCH commands for VMS volumes on non-VMS systems. These
+ can be used to find out what is on a VMS volume, and copy
+ files onto the local file sytem.
+
+See aaareadme.txt and aaareadme.too for more information.
+
+WWW: http://www.goatley.com/hunter/