aboutsummaryrefslogtreecommitdiff
path: root/sysutils/open
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-25 14:44:36 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-25 14:44:36 +0000
commit55d4094206d9f20e2f26c9de69812b0b89765978 (patch)
tree718da83d6e5ef1afcf0331870e7d4d7a1db71d39 /sysutils/open
parente5f237f9a0138fa63081da28cd17c9760a392959 (diff)
downloadports-55d4094206d9f20e2f26c9de69812b0b89765978.tar.gz
ports-55d4094206d9f20e2f26c9de69812b0b89765978.zip
Notes
Diffstat (limited to 'sysutils/open')
-rw-r--r--sysutils/open/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/sysutils/open/Makefile b/sysutils/open/Makefile
index c3653bcbc2e3..7072cd51169d 100644
--- a/sysutils/open/Makefile
+++ b/sysutils/open/Makefile
@@ -12,24 +12,21 @@ MAINTAINER= fjoe@FreeBSD.org
COMMENT= Open opens a new vt and runs a command on it
ALL_TARGET= open
-MAN1= open.1
-PLIST_FILES= bin/open
+PLIST_FILES= bin/open man/man1/open.1.gz
OPTIONS_DEFINE= SETUID
SETUID_DESC= Install setuid open binary
PKGMESSAGE= ${WRKDIR}/pkg-message
-NO_STAGE= yes
.include <bsd.port.options.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/open ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/open.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/open ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/open.1 ${STAGEDIR}${MANPREFIX}/man/man1
.if ${PORT_OPTIONS:MSETUID}
- ${CHMOD} u+s ${PREFIX}/bin/open
+ ${CHMOD} u+s ${STAGEDIR}${PREFIX}/bin/open
.else
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \
${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
- @${CAT} ${PKGMESSAGE}
.endif
.include <bsd.port.mk>