aboutsummaryrefslogtreecommitdiff
path: root/sysutils/openipmi
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-02 09:05:43 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-02 09:05:43 +0000
commitb22a9bc25a7bba96c9bd20a3305ba3da88bcc85d (patch)
treea900aa8f7c7ddf738dcdf7888ef66c351db0e758 /sysutils/openipmi
parente2fb209bbb4ebdb634a9f38a06abc4dff24a63d7 (diff)
downloadports-b22a9bc25a7bba96c9bd20a3305ba3da88bcc85d.tar.gz
ports-b22a9bc25a7bba96c9bd20a3305ba3da88bcc85d.zip
sysutils/openipmi: Remove GLIB12 option
devel/glib12 is gone since r488008. Add missing USES=gnome while here.
Notes
Notes: svn path=/head/; revision=491923
Diffstat (limited to 'sysutils/openipmi')
-rw-r--r--sysutils/openipmi/Makefile21
-rw-r--r--sysutils/openipmi/files/extra-patch-glib_glib__os__hnd.c33
2 files changed, 4 insertions, 50 deletions
diff --git a/sysutils/openipmi/Makefile b/sysutils/openipmi/Makefile
index 88acbded2f36..771ca5977922 100644
--- a/sysutils/openipmi/Makefile
+++ b/sysutils/openipmi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openipmi
PORTVERSION= 2.0.26
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/OpenIPMI%202.0%20Library
DISTNAME= OpenIPMI-${PORTVERSION}
@@ -22,9 +23,7 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= SSL SNMP PERL PYTHON TCL TKINTER GDBM
-OPTIONS_RADIO= GLIB
-OPTIONS_RADIO_GLIB= GLIB12 GLIB20
+OPTIONS_DEFINE= GDBM GLIB20 PERL PYTHON SNMP SSL TCL TKINTER
SSL_DESC= IPMI 2.0 RMCP+ encryption and authentication
SNMP_DESC= SNMP trap support for the sample programs
PERL_DESC= Perl interface for OpenIPMI library
@@ -32,7 +31,6 @@ PYTHON_DESC= Python interface for OpenIPMI library
TCL_DESC= TCL interface for OpenIPMI library
TKINTER_DESC= GUI for OpenIPMI, written in Python
GDBM_DESC= Local SDR caching on startup
-GLIB12_DESC= Simply OS handler for glib 1.2
GLIB20_DESC= Simply OS handler for glib 2.0
.include <bsd.port.options.mk>
@@ -107,20 +105,9 @@ PLIST_SUB+= TCL="@comment "
LIB_DEPENDS+= libgdbm.so:databases/gdbm
.endif
-.if ${PORT_OPTIONS:MGLIB12}
-USE_GNOME= glib12
-CONFIGURE_ARGS+= --with-glib --with-glibver=1.2 \
- --with-glibcflags=-I${LOCALBASE}/include/glib-1.2 \
- --with-gliblibs="-L${LOCALBASE}/lib -lglib -lgthread"
-MAKE_ENV+= GLIB_MAJOR_VERSION=1
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-glib_glib__os__hnd.c
-PLIST_SUB+= GLIB=""
-.else
-PLIST_SUB+= GLIB="@comment "
-.endif
-
.if ${PORT_OPTIONS:MGLIB20}
-USE_GNOME= glib20
+USES+= gnome
+USE_GNOME+= glib20
CONFIGURE_ARGS+= --with-glib --with-glibver=2.0
PLIST_SUB+= GLIB=""
.else
diff --git a/sysutils/openipmi/files/extra-patch-glib_glib__os__hnd.c b/sysutils/openipmi/files/extra-patch-glib_glib__os__hnd.c
deleted file mode 100644
index 9908271e246d..000000000000
--- a/sysutils/openipmi/files/extra-patch-glib_glib__os__hnd.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- glib/glib_os_hnd.c.orig 2015-06-25 22:51:39.000000000 +0000
-+++ glib/glib_os_hnd.c 2018-07-30 13:30:17.799255000 +0000
-@@ -777,23 +777,21 @@
- {
- gint64 now;
-
-- now = g_get_monotonic_time();
-- tv->tv_sec = now / G_TIME_SPAN_SECOND;
-- tv->tv_usec = now % G_TIME_SPAN_SECOND;
-+ g_get_current_time(&now);
-+ tv->tv_sec = now / 1000000;
-+ tv->tv_usec = now % 1000000;
- return 0;
- }
-
- static int get_glib_time(os_handler_t *handler,
- struct timeval *tv)
- {
-- GDateTime *now;
-+ GTimeVal now;
- GTimeVal gtv;
-
-- now = g_date_time_new_now_utc();
-- g_date_time_to_timeval(now, &gtv);
-- g_date_time_unref(now);
-- tv->tv_sec = gtv.tv_sec;
-- tv->tv_usec = gtv.tv_usec;
-+ g_get_current_time(&now);
-+ tv->tv_sec = now.tv_sec;
-+ tv->tv_usec = now.tv_usec;
- return 0;
- }
-