aboutsummaryrefslogtreecommitdiff
path: root/sysutils/openupsd/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-17 09:25:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-17 09:25:37 +0000
commitbc8ecab0f46c5b900e7724911acc01bda53a3bf6 (patch)
tree19fc987969ca0cb2e351898d6d004cf826db740a /sysutils/openupsd/Makefile
parent7602e7208d2e95edd6ef4f6dd9df4e0a9164be19 (diff)
downloadports-bc8ecab0f46c5b900e7724911acc01bda53a3bf6.tar.gz
ports-bc8ecab0f46c5b900e7724911acc01bda53a3bf6.zip
Notes
Diffstat (limited to 'sysutils/openupsd/Makefile')
-rw-r--r--sysutils/openupsd/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/sysutils/openupsd/Makefile b/sysutils/openupsd/Makefile
new file mode 100644
index 000000000000..105d22f20038
--- /dev/null
+++ b/sysutils/openupsd/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: openupsd
+# Date created: 15 August 2004
+# Whom: Tim Bishop <tim@bishnet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openupsd
+PORTVERSION= 0.3.0
+CATEGORIES= sysutils
+MASTER_SITES= http://frmb.org/download/
+
+MAINTAINER= tim@bishnet.net
+COMMENT= A UPS daemon for some Belkin UPS's
+
+USE_RC_SUBR= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-transform-name= --bindir=${PREFIX}/sbin
+
+PLIST_FILES= sbin/openupsd etc/openupsd.conf.sample etc/rc.d/openupsd.sh
+
+post-extract:
+ @${SED} -e 's#%%RC_SUBR%%#${RC_SUBR}#g' -e 's#%%PREFIX%%#${PREFIX}#g' \
+ ${FILESDIR}/openupsd.sh > ${WRKDIR}/openupsd.sh
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/openupsd.conf ${PREFIX}/etc/openupsd.conf.sample
+ ${INSTALL_SCRIPT} ${WRKDIR}/openupsd.sh ${PREFIX}/etc/rc.d/
+
+.include <bsd.port.mk>