aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-BSD-Jail-Object
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-09 02:53:50 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-09 02:53:50 +0000
commit6bb2039abba3609e85c01e2eb4ae184a83e5d1f7 (patch)
treeed823001b06222d46f002cfd68a89893ee82e71d /sysutils/p5-BSD-Jail-Object
parent4a8a64a1de964ad12edf7985df0078816a984675 (diff)
downloadports-6bb2039abba3609e85c01e2eb4ae184a83e5d1f7.tar.gz
ports-6bb2039abba3609e85c01e2eb4ae184a83e5d1f7.zip
Add p5-BSD-Jail-Object 0.02, an object oriented perl interface to
jail(2). PR: ports/101643 Submitted by: Mahlon E. Smith <mahlon at martini.nu>
Notes
Notes: svn path=/head/; revision=170159
Diffstat (limited to 'sysutils/p5-BSD-Jail-Object')
-rw-r--r--sysutils/p5-BSD-Jail-Object/Makefile35
-rw-r--r--sysutils/p5-BSD-Jail-Object/distinfo3
-rw-r--r--sysutils/p5-BSD-Jail-Object/pkg-descr19
-rw-r--r--sysutils/p5-BSD-Jail-Object/pkg-plist11
4 files changed, 68 insertions, 0 deletions
diff --git a/sysutils/p5-BSD-Jail-Object/Makefile b/sysutils/p5-BSD-Jail-Object/Makefile
new file mode 100644
index 000000000000..8c4b653a37d5
--- /dev/null
+++ b/sysutils/p5-BSD-Jail-Object/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: sysutils/p5-BSD-Jail-Object
+# Date created: 2006-08-07
+# Whom: Mahlon E. Smith <mahlon@martini.nu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BSD-Jail-Object
+PORTVERSION= 0.02
+CATEGORIES= sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/M/MA/MAHLON
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mahlon@martini.nu
+COMMENT= An object oriented perl interface to jail(2)
+
+BUILD_DEPENDS=\
+ ${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline
+
+PERL_CONFIGURE= yes
+
+MAN3= BSD::Jail::Object.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500806
+IGNORE= requires perl 5.8.6 or later. Install lang/perl5.8 then try again
+.endif
+
+.if ${OSVERSION} < 503100 # ref: jail.h v1.17
+IGNORE= require xprison structure defined
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/p5-BSD-Jail-Object/distinfo b/sysutils/p5-BSD-Jail-Object/distinfo
new file mode 100644
index 000000000000..fd62e0b40d33
--- /dev/null
+++ b/sysutils/p5-BSD-Jail-Object/distinfo
@@ -0,0 +1,3 @@
+MD5 (BSD-Jail-Object-0.02.tar.gz) = 7cff670f41dd536b1b0313161e40d252
+SHA256 (BSD-Jail-Object-0.02.tar.gz) = 9ae2cdd9164e3d8737ffbe63b9655e64aeb74b596ca523ca54379ac80fd3b7f1
+SIZE (BSD-Jail-Object-0.02.tar.gz) = 4695
diff --git a/sysutils/p5-BSD-Jail-Object/pkg-descr b/sysutils/p5-BSD-Jail-Object/pkg-descr
new file mode 100644
index 000000000000..a4b60539d1d2
--- /dev/null
+++ b/sysutils/p5-BSD-Jail-Object/pkg-descr
@@ -0,0 +1,19 @@
+This is an object oriented perl interface to the FreeBSD jail subsystem.
+
+Here's a replica of the 'jls' utility in just a few lines of perl:
+
+ use BSD::Jail::Object 'jids';
+
+ print " JID IP Address Hostname Path\n";
+ printf "%6d %-15.15s %-29.29s %.74s\n",
+ $_->jid, $_->ip, $_->hostname, $_->path foreach jids( instantiate => 1 );
+
+And here's 'jexec':
+
+ my $j = BSD::Jail::Object->new( $ARGV[0] ) or die $@;
+ $j->attach && chdir('/') && exec $ARGV[1] or exit;
+
+For more info please use 'perldoc' on the module.
+
+Author: Mahlon E. Smith <mahlon@martini.nu>
+WWW: http://search.cpan.org/dist//BSD-Jail-Object/
diff --git a/sysutils/p5-BSD-Jail-Object/pkg-plist b/sysutils/p5-BSD-Jail-Object/pkg-plist
new file mode 100644
index 000000000000..272e1a037e24
--- /dev/null
+++ b/sysutils/p5-BSD-Jail-Object/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/BSD/Jail/Object.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/BSD/Jail/Object/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/BSD/Jail/Object/Object.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/BSD/Jail/Object/Object.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/BSD/Jail/Object
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/BSD/Jail/Object
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/BSD/Jail
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/BSD
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/BSD/Jail/Object
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/BSD/Jail
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/BSD