aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-BSD-Process
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-04-12 02:43:33 +0000
committerSteve Wills <swills@FreeBSD.org>2011-04-12 02:43:33 +0000
commit0532c4a226bfd5131ebf3c919bdac92efb23fc6c (patch)
tree0317861c903f41293234aa589e5bd05f016b6a66 /sysutils/p5-BSD-Process
parent94adca4af96ece6179ebf18c7a19693b35f024da (diff)
downloadports-0532c4a226bfd5131ebf3c919bdac92efb23fc6c.tar.gz
ports-0532c4a226bfd5131ebf3c919bdac92efb23fc6c.zip
Information about running processes on BSD platforms
Notes
Notes: svn path=/head/; revision=272564
Diffstat (limited to 'sysutils/p5-BSD-Process')
-rw-r--r--sysutils/p5-BSD-Process/Makefile31
-rw-r--r--sysutils/p5-BSD-Process/distinfo2
-rw-r--r--sysutils/p5-BSD-Process/files/patch-Process-xs12
-rw-r--r--sysutils/p5-BSD-Process/pkg-descr3
-rw-r--r--sysutils/p5-BSD-Process/pkg-plist10
5 files changed, 58 insertions, 0 deletions
diff --git a/sysutils/p5-BSD-Process/Makefile b/sysutils/p5-BSD-Process/Makefile
new file mode 100644
index 000000000000..e527a77e57e5
--- /dev/null
+++ b/sysutils/p5-BSD-Process/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-BSD-Process
+# Date created: 2011-04-11
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BSD-Process
+PORTVERSION= 0.06
+CATEGORIES= sysutils perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DLAND
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Information about running processes on BSD platforms
+
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= BSD::Process.3
+
+post-install:
+.for script in procinfo showprocattr topten
+ @${INSTALL_SCRIPT} ${WRKSRC}/eg/${script} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-BSD-Process/distinfo b/sysutils/p5-BSD-Process/distinfo
new file mode 100644
index 000000000000..26e20857724b
--- /dev/null
+++ b/sysutils/p5-BSD-Process/distinfo
@@ -0,0 +1,2 @@
+SHA256 (BSD-Process-0.06.tar.gz) = 6bdd6902900152659d48e5fca11f62e2561f7408e4aecbea1b1a8b3f9e513ac6
+SIZE (BSD-Process-0.06.tar.gz) = 25727
diff --git a/sysutils/p5-BSD-Process/files/patch-Process-xs b/sysutils/p5-BSD-Process/files/patch-Process-xs
new file mode 100644
index 000000000000..c152b9c94e80
--- /dev/null
+++ b/sysutils/p5-BSD-Process/files/patch-Process-xs
@@ -0,0 +1,12 @@
+--- Process.xs.orig 2011-04-11 22:08:32.577420432 -0400
++++ Process.xs 2011-04-11 22:10:26.129419839 -0400
+@@ -287,7 +287,9 @@
+ hv_store(h, "advlock", 7, newSViv(NO_FREEBSD_4x(P_FLAG(P_ADVLOCK))), 0);
+ hv_store(h, "controlt", 8, newSViv(NO_FREEBSD_4x(P_FLAG(P_CONTROLT))), 0);
+ hv_store(h, "kthread", 7, newSViv(NO_FREEBSD_4x(P_FLAG(P_KTHREAD))), 0);
++#if __FreeBSD_version < 802501
+ hv_store(h, "noload", 6, newSViv(NO_FREEBSD_4x(P_FLAG(P_NOLOAD))), 0);
++#endif
+ hv_store(h, "ppwait", 6, newSViv(NO_FREEBSD_4x(P_FLAG(P_PPWAIT))), 0);
+ hv_store(h, "profil", 6, newSViv(NO_FREEBSD_4x(P_FLAG(P_PROFIL))), 0);
+ hv_store(h, "stopprof", 8, newSViv(NO_FREEBSD_4x(P_FLAG(P_STOPPROF))), 0);
diff --git a/sysutils/p5-BSD-Process/pkg-descr b/sysutils/p5-BSD-Process/pkg-descr
new file mode 100644
index 000000000000..09f281f69f42
--- /dev/null
+++ b/sysutils/p5-BSD-Process/pkg-descr
@@ -0,0 +1,3 @@
+Information about running processes on BSD platforms
+
+WWW: http://search.cpan.org/dist/BSD-Process/
diff --git a/sysutils/p5-BSD-Process/pkg-plist b/sysutils/p5-BSD-Process/pkg-plist
new file mode 100644
index 000000000000..957e082c39ac
--- /dev/null
+++ b/sysutils/p5-BSD-Process/pkg-plist
@@ -0,0 +1,10 @@
+bin/procinfo
+bin/showprocattr
+bin/topten
+%%SITE_PERL%%/%%PERL_ARCH%%/BSD/Process.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/BSD/Process/Process.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/BSD/Process/Process.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/BSD/Process/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/BSD/Process
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/BSD
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/BSD