aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-Fuse
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-27 04:56:21 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-27 04:56:21 +0000
commit0e07c2291db5a52022a15d9e9c9afeb5aa592692 (patch)
treea6394e679ac71be2d3a90b9fab8b9d280d2c5453 /sysutils/p5-Fuse
parent9d3c591e21758d3268ba80225790e963e26a7415 (diff)
downloadports-0e07c2291db5a52022a15d9e9c9afeb5aa592692.tar.gz
ports-0e07c2291db5a52022a15d9e9c9afeb5aa592692.zip
Add p5-Fuse 0.07, write filesystems in Perl using FUSE.
PR: ports/100415 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=168850
Diffstat (limited to 'sysutils/p5-Fuse')
-rw-r--r--sysutils/p5-Fuse/Makefile32
-rw-r--r--sysutils/p5-Fuse/distinfo3
-rw-r--r--sysutils/p5-Fuse/pkg-descr16
-rw-r--r--sysutils/p5-Fuse/pkg-plist8
4 files changed, 59 insertions, 0 deletions
diff --git a/sysutils/p5-Fuse/Makefile b/sysutils/p5-Fuse/Makefile
new file mode 100644
index 000000000000..fdd953664c9c
--- /dev/null
+++ b/sysutils/p5-Fuse/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Fuse
+# Date created: 2006-07-17
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Fuse
+PORTVERSION= 0.07
+CATEGORIES= sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/D/DP/DPAVLIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Write filesystems in Perl using FUSE
+
+RUN_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+USE_GNOME= pkgconfig
+
+MAN3= Fuse.3
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000 # Inherited from sysutils/fusefs-libs
+IGNORE= depends on kernel module that requires FreeBSD 6 or later
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/p5-Fuse/distinfo b/sysutils/p5-Fuse/distinfo
new file mode 100644
index 000000000000..80a256616f50
--- /dev/null
+++ b/sysutils/p5-Fuse/distinfo
@@ -0,0 +1,3 @@
+MD5 (Fuse-0.07.tar.gz) = 9e8b2338ada7ef1e25f1b5bf7769b03c
+SHA256 (Fuse-0.07.tar.gz) = f1c48be240f0becf46877344d8318ade40d6a6d3562c310d7b815e4eed2ea334
+SIZE (Fuse-0.07.tar.gz) = 20134
diff --git a/sysutils/p5-Fuse/pkg-descr b/sysutils/p5-Fuse/pkg-descr
new file mode 100644
index 000000000000..ef7f8d6f55cd
--- /dev/null
+++ b/sysutils/p5-Fuse/pkg-descr
@@ -0,0 +1,16 @@
+This lets you implement filesystems in perl, through the FUSE
+(Filesystem in USErspace) kernel/lib interface.
+
+FUSE expects you to implement callbacks for the various functions.
+
+In the following definitions, "errno" can be 0 (for a success),
+-EINVAL, -ENOENT, -EONFIRE, any integer less than 1 really.
+
+You can import standard error constants by saying something like "use
+POSIX qw(EDOTDOT ENOANO);".
+
+Every constant you need (file types, open() flags, error values, etc)
+can be imported either from POSIX or from Fcntl, often both. See their
+respective documentations, for more information.
+
+WWW: http://search.cpan.org/dist/Fuse/
diff --git a/sysutils/p5-Fuse/pkg-plist b/sysutils/p5-Fuse/pkg-plist
new file mode 100644
index 000000000000..dbfc58ee7f19
--- /dev/null
+++ b/sysutils/p5-Fuse/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/Fuse.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Fuse/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Fuse/Fuse.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Fuse/Fuse.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Fuse/autosplit.ix
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Fuse
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Fuse