aboutsummaryrefslogtreecommitdiff
path: root/sysutils/parafly
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-03-18 14:14:41 +0000
committerSteve Wills <swills@FreeBSD.org>2016-03-18 14:14:41 +0000
commitf85e37560bd1600f05048c87e296e6c192efd32a (patch)
tree078776820b5e2fb19db810187c4bd4eec3bfba89 /sysutils/parafly
parent93677d11569038bd9d9143e3b44ec6532670005e (diff)
downloadports-f85e37560bd1600f05048c87e296e6c192efd32a.tar.gz
ports-f85e37560bd1600f05048c87e296e6c192efd32a.zip
sysutils/parafly: create port
Given a file containing a list of Unix commands, multithreading is used to process the commands in parallel on a single server. Success/failure is captured, and failed commands are retained and reported. WWW: http://sourceforge.net/projects/parafly/ PR: 207960 Submitted by: Jason Bacon <bacon4000@gmail.com>
Notes
Notes: svn path=/head/; revision=411357
Diffstat (limited to 'sysutils/parafly')
-rw-r--r--sysutils/parafly/Makefile24
-rw-r--r--sysutils/parafly/distinfo2
-rw-r--r--sysutils/parafly/files/patch-configure11
-rw-r--r--sysutils/parafly/pkg-descr5
4 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/parafly/Makefile b/sysutils/parafly/Makefile
new file mode 100644
index 000000000000..64a3dc15a356
--- /dev/null
+++ b/sysutils/parafly/Makefile
@@ -0,0 +1,24 @@
+# Created by: Jason Bacon <bacon4000@gmail.com>
+# $FreeBSD$
+
+PORTNAME= parafly
+PORTVERSION= 2013.01.21
+CATEGORIES= sysutils
+MASTER_SITES= SF/${PORTNAME}/
+DISTNAME= ${PORTNAME}-r2013-01-21
+
+MAINTAINER= bacon4000@gmail.com
+COMMENT= Process multiple commands in parallel on a single server
+
+LICENSE= BSD3CLAUSE
+
+USES= compiler:openmp tar:tgz
+
+GNU_CONFIGURE= yes
+
+CXXFLAGS+= -fopenmp
+LDFLAGS+= -fopenmp
+
+PLIST_FILES= bin/ParaFly
+
+.include <bsd.port.mk>
diff --git a/sysutils/parafly/distinfo b/sysutils/parafly/distinfo
new file mode 100644
index 000000000000..56a5a2fdc558
--- /dev/null
+++ b/sysutils/parafly/distinfo
@@ -0,0 +1,2 @@
+SHA256 (parafly-r2013-01-21.tgz) = 64cf7ac2d4af0801b78d58f4057a1489d76b2b8ae59c78997f434d1239fa4abe
+SIZE (parafly-r2013-01-21.tgz) = 198711
diff --git a/sysutils/parafly/files/patch-configure b/sysutils/parafly/files/patch-configure
new file mode 100644
index 000000000000..63b65bf92094
--- /dev/null
+++ b/sysutils/parafly/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2013-01-22 01:21:10 UTC
++++ configure
+@@ -3016,7 +3016,7 @@ fi
+
+
+ #AC_OPENMP # requires autoconf >= 2.62
+-AM_CXXFLAGS=-m64
++#AM_CXXFLAGS=-m64
+
+ case $CXX in
+ g++*) AM_CXXFLAGS="-pedantic -fopenmp -Wall -Wextra -Wno-long-long -Wno-deprecated $AM_CXXFLAGS"
diff --git a/sysutils/parafly/pkg-descr b/sysutils/parafly/pkg-descr
new file mode 100644
index 000000000000..c50b7413b697
--- /dev/null
+++ b/sysutils/parafly/pkg-descr
@@ -0,0 +1,5 @@
+Given a file containing a list of Unix commands, multithreading is used to
+process the commands in parallel on a single server. Success/failure is
+captured, and failed commands are retained and reported.
+
+WWW: http://sourceforge.net/projects/parafly/