aboutsummaryrefslogtreecommitdiff
path: root/sysutils/parallel
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-23 03:46:37 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-23 03:46:37 +0000
commit09bc07c9774631ada7a30e96bdf121e2a749e964 (patch)
treead1c178f664bbd1fc826a4e66e99a25b0f6e75aa /sysutils/parallel
parentb57bac69863705d77b78102e09a4019aeea4c12e (diff)
downloadports-09bc07c9774631ada7a30e96bdf121e2a749e964.tar.gz
ports-09bc07c9774631ada7a30e96bdf121e2a749e964.zip
Notes
Diffstat (limited to 'sysutils/parallel')
-rw-r--r--sysutils/parallel/Makefile31
-rw-r--r--sysutils/parallel/distinfo3
-rw-r--r--sysutils/parallel/pkg-descr18
-rw-r--r--sysutils/parallel/pr-patch0
4 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/parallel/Makefile b/sysutils/parallel/Makefile
new file mode 100644
index 000000000000..602513512a32
--- /dev/null
+++ b/sysutils/parallel/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: parallel
+# Date created: 22 September 2010
+# Whom: Chris Howey <howeyc@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= parallel
+PORTVERSION= 20100922
+CATEGORIES= sysutils
+MASTER_SITES= GNU
+
+MAINTAINER= howeyc@gmail.com
+COMMENT= GNU parallel is a shell tool for executing jobs in parallel
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --datarootdir="${PREFIX}"\
+ --docdir="${PREFIX}/share/doc/${PORTNAME}"
+
+MAN1= parallel.1 sem.1 sql.1
+MANCOMPRESSED= no
+USE_BZIP2= yes
+USE_PERL5= yes
+
+PORTDOCS= parallel.html sem.html sql.html
+
+PLIST_FILES= bin/parallel \
+ bin/sem \
+ bin/sql
+
+.include <bsd.port.mk>
diff --git a/sysutils/parallel/distinfo b/sysutils/parallel/distinfo
new file mode 100644
index 000000000000..a521a926fabf
--- /dev/null
+++ b/sysutils/parallel/distinfo
@@ -0,0 +1,3 @@
+MD5 (parallel-20100922.tar.bz2) = d394fda57fbe7a58f64b3c2eaa5ad177
+SHA256 (parallel-20100922.tar.bz2) = 0dbd93c569d177baa36cd281d53b079be761dc276d72505ba9ef0a22d4bcc12e
+SIZE (parallel-20100922.tar.bz2) = 125602
diff --git a/sysutils/parallel/pkg-descr b/sysutils/parallel/pkg-descr
new file mode 100644
index 000000000000..a89818fc5b3f
--- /dev/null
+++ b/sysutils/parallel/pkg-descr
@@ -0,0 +1,18 @@
+GNU Parallel is a shell tool for executing jobs in parallel using one
+or more machines. A job is typically a single command or a small
+script that has to be run for each of the lines in the input. The
+typical input is a list of files, a list of hosts, a list of users, or
+a list of tables.
+
+If you use xargs today you will find GNU Parallel very easy to use. If
+you write loops in shell, you will find GNU Parallel may be able to
+replace most of the loops and make them run faster by running jobs in
+parallel. If you use ppss or pexec you will find GNU Parallel will
+often make the command easier to read.
+
+GNU Parallel also makes sure output from the commands is the same
+output as you would get had you run the commands sequentially. This
+makes it possible to use output from GNU Parallel as input for other
+programs.
+
+WWW: http://www.gnu.org/software/parallel/
diff --git a/sysutils/parallel/pr-patch b/sysutils/parallel/pr-patch
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sysutils/parallel/pr-patch