aboutsummaryrefslogtreecommitdiff
path: root/sysutils/password-store
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2019-01-30 19:47:48 +0000
committerRene Ladan <rene@FreeBSD.org>2019-01-30 19:47:48 +0000
commitdffde4070d571b9509ae4098b395ea9542c87a06 (patch)
treea14cc00ea7a7c6db0ea635b7a883ebecddce2613 /sysutils/password-store
parent2c4a634b0a4114f5892eb371d4730426d010861a (diff)
downloadports-dffde4070d571b9509ae4098b395ea9542c87a06.tar.gz
ports-dffde4070d571b9509ae4098b395ea9542c87a06.zip
sysutils/password-store: install extensions into libexec instead of lib
This is more in line with hier(7) PR: 235255 Submitted by: tobias.rehbein@web.de
Notes
Notes: svn path=/head/; revision=491655
Diffstat (limited to 'sysutils/password-store')
-rw-r--r--sysutils/password-store/Makefile10
-rw-r--r--sysutils/password-store/files/pass.in4
-rw-r--r--sysutils/password-store/pkg-plist5
3 files changed, 11 insertions, 8 deletions
diff --git a/sysutils/password-store/Makefile b/sysutils/password-store/Makefile
index d27affd29f33..136ec7d6190a 100644
--- a/sysutils/password-store/Makefile
+++ b/sysutils/password-store/Makefile
@@ -2,6 +2,7 @@
PORTNAME= password-store
PORTVERSION= 1.7.3
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://git.zx2c4.com/password-store/snapshot/
@@ -42,14 +43,15 @@ SUB_FILES= pass
post-patch:
@${REINPLACE_CMD} -Ee 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/src/platform/freebsd.sh
- @${REINPLACE_CMD} -Ee 's|^SYSTEM_EXTENSION_DIR=""|SYSTEM_EXTENSION_DIR="${PREFIX}/lib/password-store/extensions"|g' \
+ @${REINPLACE_CMD} -Ee 's|^SYSTEM_EXTENSION_DIR=""|SYSTEM_EXTENSION_DIR="${PREFIX}/libexec/password-store/extensions"|g' \
${WRKSRC}/src/password-store.sh
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/pass ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKSRC}/src/password-store.sh ${STAGEDIR}${PREFIX}/libexec/pass
- ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/platform
- ${INSTALL_SCRIPT} ${WRKSRC}/src/platform/freebsd.sh ${STAGEDIR}${PREFIX}/libexec/platform/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/password-store/extensions
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/password-store/platform
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/password-store.sh ${STAGEDIR}${PREFIX}/libexec/password-store/pass
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/platform/freebsd.sh ${STAGEDIR}${PREFIX}/libexec/password-store/platform/
${INSTALL_MAN} ${WRKSRC}/man/pass.1 ${STAGEDIR}${MANPREFIX}/man/man1/pass.1
do-install-CONTRIB-on:
diff --git a/sysutils/password-store/files/pass.in b/sysutils/password-store/files/pass.in
index 027f7665591d..4983e10c0c30 100644
--- a/sysutils/password-store/files/pass.in
+++ b/sysutils/password-store/files/pass.in
@@ -1,4 +1,4 @@
#!/bin/sh
-cd %%PREFIX%%/libexec
-exec %%PREFIX%%/libexec/pass "$@"
+cd %%PREFIX%%/libexec/password-store
+exec %%PREFIX%%/libexec/password-store/pass "$@"
diff --git a/sysutils/password-store/pkg-plist b/sysutils/password-store/pkg-plist
index bd33154f9c45..fa25fba840bf 100644
--- a/sysutils/password-store/pkg-plist
+++ b/sysutils/password-store/pkg-plist
@@ -1,6 +1,6 @@
bin/pass
-libexec/pass
-libexec/platform/freebsd.sh
+libexec/password-store/pass
+libexec/password-store/platform/freebsd.sh
man/man1/pass.1.gz
%%CONTRIB%%%%DATADIR%%/dmenu/README.md
%%CONTRIB%%%%DATADIR%%/dmenu/passmenu
@@ -32,3 +32,4 @@ man/man1/pass.1.gz
%%CONTRIB%%share/fish/completions/password-store.fish
%%CONTRIB%%share/zsh/site-functions/_pass
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example-filter.sh
+@dir libexec/password-store/extensions