aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pax-utils
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2016-12-17 20:13:51 +0000
committerSofian Brabez <sbz@FreeBSD.org>2016-12-17 20:13:51 +0000
commitcbd9990b69e7b8450dfd9f2666e98c5773ec8538 (patch)
tree686aa237b8299f8fa3b3c48e3a4d3c110b53e1c7 /sysutils/pax-utils
parent404040d4e5a88aa807a3e5576e811bbd2fb8fa4d (diff)
downloadports-cbd9990b69e7b8450dfd9f2666e98c5773ec8538.tar.gz
ports-cbd9990b69e7b8450dfd9f2666e98c5773ec8538.zip
Notes
Diffstat (limited to 'sysutils/pax-utils')
-rw-r--r--sysutils/pax-utils/Makefile5
-rw-r--r--sysutils/pax-utils/distinfo5
-rw-r--r--sysutils/pax-utils/files/patch-Makefile11
-rw-r--r--sysutils/pax-utils/files/patch-scanelf.c13
4 files changed, 6 insertions, 28 deletions
diff --git a/sysutils/pax-utils/Makefile b/sysutils/pax-utils/Makefile
index 66fea6abf70b..dfcadc9a71a5 100644
--- a/sysutils/pax-utils/Makefile
+++ b/sysutils/pax-utils/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pax-utils
-PORTVERSION= 0.7
+PORTVERSION= 1.1.7
CATEGORIES= sysutils
MASTER_SITES= http://dev.gentoo.org/~vapier/dist/ \
LOCAL/sbz
@@ -11,13 +11,14 @@ MAINTAINER= sbz@FreeBSD.org
COMMENT= Various ELF related utils for ELF32, ELF64 binaries
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake tar:xz
PLIST_FILES= bin/dumpelf bin/pspax bin/scanelf bin/scanmacho \
man/man1/dumpelf.1.gz man/man1/pspax.1.gz \
man/man1/scanelf.1.gz man/man1/scanmacho.1.gz
-PORTDOCS= BUGS README TODO
+PORTDOCS= BUGS COPYING README.md TODO
OPTIONS_DEFINE= DOCS
diff --git a/sysutils/pax-utils/distinfo b/sysutils/pax-utils/distinfo
index ae73e4bacf54..d92e5c082cec 100644
--- a/sysutils/pax-utils/distinfo
+++ b/sysutils/pax-utils/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pax-utils-0.7.tar.xz) = 1ac4cee9a9ca97a723505eb29a25e50adeccffba3f0f0ef4f035cf082caf3b84
-SIZE (pax-utils-0.7.tar.xz) = 90188
+TIMESTAMP = 1482004695
+SHA256 (pax-utils-1.1.7.tar.xz) = bb9bdbf0888de9444b53b78f7b8069af9832bac7cef0588030b8ce49e8ebad10
+SIZE (pax-utils-1.1.7.tar.xz) = 648376
diff --git a/sysutils/pax-utils/files/patch-Makefile b/sysutils/pax-utils/files/patch-Makefile
deleted file mode 100644
index d471ebf4b80f..000000000000
--- a/sysutils/pax-utils/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Makefile.orig 2012-05-12 19:01:03.000000000 +0200
-+++ ./Makefile 2012-05-12 19:03:03.000000000 +0200
-@@ -107,7 +107,7 @@
- for sh in *.sh ; do $(INS_EXE) $$sh $(PREFIX)/bin/$${sh%.sh} || exit $$? ; done
- $(INS_EXE) $(TARGETS) $(PREFIX)/bin/
- $(INS_DATA) README BUGS TODO $(PKGDOCDIR)/
-- $(INS_DATA) $(MPAGES) $(MANDIR)/man1/
-+ $(INS_DATA) $(MPAGES) $(MANPREFIX)/man1/
-
- PN = pax-utils
- P = $(PN)-$(PV)
diff --git a/sysutils/pax-utils/files/patch-scanelf.c b/sysutils/pax-utils/files/patch-scanelf.c
deleted file mode 100644
index 60ea1096ea24..000000000000
--- a/sysutils/pax-utils/files/patch-scanelf.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./scanelf.c.orig 2012-05-12 19:03:38.000000000 +0200
-+++ ./scanelf.c 2012-05-12 19:04:14.000000000 +0200
-@@ -14,6 +14,10 @@
-
- #define IS_MODIFIER(c) (c == '%' || c == '#' || c == '+')
-
-+#ifndef O_CLOEXEC
-+#define O_CLOEXEC 0x00100000
-+#endif
-+
- /* prototypes */
- static int file_matches_list(const char *filename, char **matchlist);
-