aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pear-Translation2
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /sysutils/pear-Translation2
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'sysutils/pear-Translation2')
-rw-r--r--sysutils/pear-Translation2/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/sysutils/pear-Translation2/Makefile b/sysutils/pear-Translation2/Makefile
index 20e3aef6e483..7bc5da375763 100644
--- a/sysutils/pear-Translation2/Makefile
+++ b/sysutils/pear-Translation2/Makefile
@@ -24,13 +24,13 @@ PEAR_FILE_GETTEXT_DESC= PEAR::File_Gettext support
PEAR_I18NV2_DESC= PEAR::I18Nv2 support
PEAR_XML_SERIALIZER_DESC= PEAR::XML_Serializer support
-PEAR_CACHE_LITE_RUN_DEPENDS= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite
-PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB
-PEAR_DB_DATAOBJECT_RUN_DEPENDS= ${PEARDIR}/DB/DataObject.php:databases/pear-DB_DataObject
-PEAR_MDB_RUN_DEPENDS= ${PEARDIR}/MDB.php:databases/pear-MDB
-PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:databases/pear-MDB2
-PEAR_FILE_GETTEXT_RUN_DEPENDS= ${PEARDIR}/File/Gettext.php:sysutils/pear-File_Gettext
-PEAR_I18NV2_RUN_DEPENDS= ${PEARDIR}/File/I18Nv2.php:sysutils/pear-I18Nv2
-PEAR_XML_SERIALIZER_RUN_DEPENDS= ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer
+PEAR_CACHE_LITE_RUN_DEPENDS= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite@${PHP_FLAVOR}
+PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB@${PHP_FLAVOR}
+PEAR_DB_DATAOBJECT_RUN_DEPENDS= ${PEARDIR}/DB/DataObject.php:databases/pear-DB_DataObject@${PHP_FLAVOR}
+PEAR_MDB_RUN_DEPENDS= ${PEARDIR}/MDB.php:databases/pear-MDB@${PHP_FLAVOR}
+PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:databases/pear-MDB2@${PHP_FLAVOR}
+PEAR_FILE_GETTEXT_RUN_DEPENDS= ${PEARDIR}/File/Gettext.php:sysutils/pear-File_Gettext@${PHP_FLAVOR}
+PEAR_I18NV2_RUN_DEPENDS= ${PEARDIR}/File/I18Nv2.php:sysutils/pear-I18Nv2@${PHP_FLAVOR}
+PEAR_XML_SERIALIZER_RUN_DEPENDS= ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer@${PHP_FLAVOR}
.include <bsd.port.mk>