aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pftables/Makefile
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-08-29 14:33:48 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-08-29 14:33:48 +0000
commit5576dfc975333bfc34a94d2a8b1b65eaab950136 (patch)
treead188758477ec9c8e0ab26cfd7b22cb1c23d3c99 /sysutils/pftables/Makefile
parent782b56aef84c4a09c19108124bbbf0b174cb9552 (diff)
Notes
Diffstat (limited to 'sysutils/pftables/Makefile')
-rw-r--r--sysutils/pftables/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/sysutils/pftables/Makefile b/sysutils/pftables/Makefile
new file mode 100644
index 000000000000..310f5272d2e9
--- /dev/null
+++ b/sysutils/pftables/Makefile
@@ -0,0 +1,28 @@
+# Created by: Thomas Zander <riggs@FreeBSD.org>
+# $FreeBSD$
+#
+
+PORTNAME= pftables
+PORTVERSION= 0.1
+CATEGORIES= sysutils
+
+MAINTAINER= riggs@FreeBSD.org
+COMMENT= Minimal rc script to save and restore pf tables upon reboots
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= riggs-
+GH_COMMIT= 6a29e7a
+GH_TAGNAME= ${GH_COMMIT}
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= etc/rc.d/pftables
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pftables ${STAGEDIR}${PREFIX}/etc/rc.d
+
+.include <bsd.port.mk>