aboutsummaryrefslogtreecommitdiff
path: root/sysutils/php74-fileinfo
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2019-09-20 12:21:11 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2019-09-20 12:21:11 +0000
commit7aca2531e2d785929c4477143e265a8d9b0b516b (patch)
tree5eb143508ff1769e64395b54d8a3b09e1576fba0 /sysutils/php74-fileinfo
parent2a5ef470852066fb4e7c665bc1bb5be0b206d82b (diff)
downloadports-7aca2531e2d785929c4477143e265a8d9b0b516b.tar.gz
ports-7aca2531e2d785929c4477143e265a8d9b0b516b.zip
Welcome PHP 7.4 RC 1 in the ports-tree.
There are many greater changes including: - New module ffi - Remove interbase module - Remove recode module - Remove wddx module - Many modules changes the build switches - Many modules changes the config format, so patches needed to be recreated Special thanks to tobik and ale for their support. Reviewed by: tobik, ale, joneum Sponsored by: PHP Update Service Differential Revision: https://reviews.freebsd.org/D21349
Notes
Notes: svn path=/head/; revision=512406
Diffstat (limited to 'sysutils/php74-fileinfo')
-rw-r--r--sysutils/php74-fileinfo/Makefile11
-rw-r--r--sysutils/php74-fileinfo/files/patch-config.m421
2 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/php74-fileinfo/Makefile b/sysutils/php74-fileinfo/Makefile
new file mode 100644
index 000000000000..c815184e57f9
--- /dev/null
+++ b/sysutils/php74-fileinfo/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= sysutils
+
+MASTERDIR= ${.CURDIR}/../../lang/php74
+
+PKGNAMESUFFIX= -fileinfo
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/php74-fileinfo/files/patch-config.m4 b/sysutils/php74-fileinfo/files/patch-config.m4
new file mode 100644
index 000000000000..1348023ccf64
--- /dev/null
+++ b/sysutils/php74-fileinfo/files/patch-config.m4
@@ -0,0 +1,21 @@
+--- config.m4.orig 2010-09-07 15:45:30.000000000 +0200
++++ config.m4 2010-09-07 15:46:50.000000000 +0200
+@@ -4,6 +4,9 @@
+ PHP_ARG_ENABLE(fileinfo, for fileinfo support,
+ [ --disable-fileinfo Disable fileinfo support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir FILEINFO: pcre install prefix], no, no)
++
+ if test "$PHP_FILEINFO" != "no"; then
+
+ libmagic_sources=" \
+@@ -13,6 +16,8 @@
+ libmagic/is_tar.c libmagic/magic.c libmagic/print.c \
+ libmagic/readcdf.c libmagic/readelf.c libmagic/softmagic.c"
+
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++
+ PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)
+ PHP_ADD_BUILD_DIR($ext_builddir/libmagic)
+