aboutsummaryrefslogtreecommitdiff
path: root/sysutils/plasma5-ksysguard
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2019-06-25 14:36:24 +0000
committerDima Panov <fluffy@FreeBSD.org>2019-06-25 14:36:24 +0000
commit37ea3156ade0e05d66d136123faa4a5476964703 (patch)
tree6303ac561267de1a09a80e331c90fe44ec42d343 /sysutils/plasma5-ksysguard
parent4b6df4a032583ab747f4027350e651bdbd1b3d25 (diff)
downloadports-37ea3156ade0e05d66d136123faa4a5476964703.tar.gz
ports-37ea3156ade0e05d66d136123faa4a5476964703.zip
- Unbreak build
- Teach ksysguardd to find Inotify by Right Way(tm) Pointyhat to: pkubaj
Notes
Notes: svn path=/head/; revision=505091
Diffstat (limited to 'sysutils/plasma5-ksysguard')
-rw-r--r--sysutils/plasma5-ksysguard/Makefile4
-rw-r--r--sysutils/plasma5-ksysguard/files/patch-CMakeLists.txt14
-rw-r--r--sysutils/plasma5-ksysguard/files/patch-ksysguardd_CMakeLists.txt19
3 files changed, 35 insertions, 2 deletions
diff --git a/sysutils/plasma5-ksysguard/Makefile b/sysutils/plasma5-ksysguard/Makefile
index fa0af478c6de..5e9ebf39ff95 100644
--- a/sysutils/plasma5-ksysguard/Makefile
+++ b/sysutils/plasma5-ksysguard/Makefile
@@ -8,7 +8,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Plasma5 utility to track and control the running processes
USES= cmake compiler:c++11-lib cpe desktop-file-utils \
- gettext kde:5 qt:5 tar:xz
+ gettext kde:5 localbase pathfix qt:5 tar:xz
USE_KDE= attica auth codecs completion config configwidgets coreaddons \
dbusaddons emoticons i18n iconthemes init itemmodels \
itemviews jobwidgets kdelibs4support kio libksysguard \
@@ -23,6 +23,6 @@ OPTIONS_SUB= yes
INOTIFY_DESC= Filesystem alteration notifications using inotify
INOTIFY_LIB_DEPENDS= libinotify.so:devel/libinotify
-INOTIFY_LDFLAGS= -linotify
+INOTIFY_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Inotify
.include <bsd.port.mk>
diff --git a/sysutils/plasma5-ksysguard/files/patch-CMakeLists.txt b/sysutils/plasma5-ksysguard/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..735a306f7310
--- /dev/null
+++ b/sysutils/plasma5-ksysguard/files/patch-CMakeLists.txt
@@ -0,0 +1,14 @@
+--- CMakeLists.txt.orig 2019-06-18 09:56:54 UTC
++++ CMakeLists.txt
+@@ -63,6 +63,11 @@ add_subdirectory( doc )
+ add_subdirectory( pics )
+ add_subdirectory( example )
+
++find_package(Inotify)
++set_package_properties(Inotify PROPERTIES
++ TYPE OPTIONAL
++ PURPOSE "Filesystem alteration notifications using inotify")
++
+ add_subdirectory( ksysguardd )
+
+ feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)
diff --git a/sysutils/plasma5-ksysguard/files/patch-ksysguardd_CMakeLists.txt b/sysutils/plasma5-ksysguard/files/patch-ksysguardd_CMakeLists.txt
new file mode 100644
index 000000000000..b9d971737e97
--- /dev/null
+++ b/sysutils/plasma5-ksysguard/files/patch-ksysguardd_CMakeLists.txt
@@ -0,0 +1,19 @@
+--- ksysguardd/CMakeLists.txt.orig 2019-06-18 09:56:21 UTC
++++ ksysguardd/CMakeLists.txt
+@@ -9,6 +9,7 @@ add_definitions(-DOSTYPE_${CMAKE_SYSTEM_NAME})
+
+ set(HAVE_LMSENSORS ${SENSORS_FOUND})
+
++include_directories(${Inotify_INCLUDE_DIRS})
+ check_include_files(sys/inotify.h SYS_INOTIFY_H_FOUND)
+ set(HAVE_SYS_INOTIFY_H ${SYS_INOTIFY_H_FOUND})
+
+@@ -46,7 +47,7 @@ endif()
+
+ add_executable(ksysguardd ${ksysguardd_SRCS})
+ set_property(TARGET ksysguardd PROPERTY C_STANDARD 11)
+- target_link_libraries(ksysguardd libksysguardd)
++ target_link_libraries(ksysguardd libksysguardd ${Inotify_LIBRARIES})
+
+ if( ${CMAKE_SYSTEM_NAME} MATCHES "NetBSD" )
+ message(STATUS "Adding kvm library on NetBSD")