aboutsummaryrefslogtreecommitdiff
path: root/sysutils/plasma5-ksysguard
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2019-06-26 10:45:33 +0000
committerDima Panov <fluffy@FreeBSD.org>2019-06-26 10:45:33 +0000
commitc65748b136fdc615b71616a367ad8cf8f3102c68 (patch)
tree3bd02b1777841263e59602c436d80264b9461018 /sysutils/plasma5-ksysguard
parent9ab01c1039dbf89643ed34f1e6dd3c4075c14be0 (diff)
downloadports-c65748b136fdc615b71616a367ad8cf8f3102c68.tar.gz
ports-c65748b136fdc615b71616a367ad8cf8f3102c68.zip
- Exclude false-positive use of sys/inotify.h when INOTIFY option disabled
Notes
Notes: svn path=/head/; revision=505149
Diffstat (limited to 'sysutils/plasma5-ksysguard')
-rw-r--r--sysutils/plasma5-ksysguard/files/patch-ksysguardd_CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/sysutils/plasma5-ksysguard/files/patch-ksysguardd_CMakeLists.txt b/sysutils/plasma5-ksysguard/files/patch-ksysguardd_CMakeLists.txt
index b9d971737e97..52392489aebe 100644
--- a/sysutils/plasma5-ksysguard/files/patch-ksysguardd_CMakeLists.txt
+++ b/sysutils/plasma5-ksysguard/files/patch-ksysguardd_CMakeLists.txt
@@ -1,14 +1,17 @@
---- ksysguardd/CMakeLists.txt.orig 2019-06-18 09:56:21 UTC
+--- ksysguardd/CMakeLists.txt.orig 2019-06-26 08:37:14 UTC
+++ ksysguardd/CMakeLists.txt
-@@ -9,6 +9,7 @@ add_definitions(-DOSTYPE_${CMAKE_SYSTEM_NAME})
+@@ -9,8 +9,8 @@ add_definitions(-DOSTYPE_${CMAKE_SYSTEM_NAME})
set(HAVE_LMSENSORS ${SENSORS_FOUND})
+-check_include_files(sys/inotify.h SYS_INOTIFY_H_FOUND)
+-set(HAVE_SYS_INOTIFY_H ${SYS_INOTIFY_H_FOUND})
+include_directories(${Inotify_INCLUDE_DIRS})
- check_include_files(sys/inotify.h SYS_INOTIFY_H_FOUND)
- set(HAVE_SYS_INOTIFY_H ${SYS_INOTIFY_H_FOUND})
++set(HAVE_SYS_INOTIFY_H ${Inotify_FOUND})
-@@ -46,7 +47,7 @@ endif()
+
+ configure_file(config-ksysguardd.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-ksysguardd.h)
+@@ -46,7 +46,7 @@ endif()
add_executable(ksysguardd ${ksysguardd_SRCS})
set_property(TARGET ksysguardd PROPERTY C_STANDARD 11)