aboutsummaryrefslogtreecommitdiff
path: root/sysutils/powermon
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2017-07-08 22:24:33 +0000
committerLars Engels <lme@FreeBSD.org>2017-07-08 22:24:33 +0000
commitb4db0b0380fd41367c5ef2d4ac59207a720260ad (patch)
tree64ee33daa2023ff0ae2cf4f097a34cc1121a18e9 /sysutils/powermon
parentdf4f951810996ea59d9243ccf94215831df6dc71 (diff)
downloadports-b4db0b0380fd41367c5ef2d4ac59207a720260ad.tar.gz
ports-b4db0b0380fd41367c5ef2d4ac59207a720260ad.zip
Add new port: sysutils/powermon
Powermon is a small utility that reads the CPU internal power counters, calculates the current power consumption and displays it together with some nice statistics on an interactive curses interface. All Intel CPUs starting with Sandy Bridge are supported. Older Intel CPUs and CPUs from other vendors don't expose the necessary performance counters. Additionally some server CPUs like those based on Haswell and Broadwell do not provide the necessary data. WWW: https://github.com/Yamagi/powermon PR: 220450 Submitted by: yamagi@yamagi.org Sponsored by: Essen Hackathon 2017
Notes
Notes: svn path=/head/; revision=445346
Diffstat (limited to 'sysutils/powermon')
-rw-r--r--sysutils/powermon/Makefile28
-rw-r--r--sysutils/powermon/distinfo3
-rw-r--r--sysutils/powermon/pkg-descr10
3 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/powermon/Makefile b/sysutils/powermon/Makefile
new file mode 100644
index 000000000000..e364279390fa
--- /dev/null
+++ b/sysutils/powermon/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= powermon
+PORTVERSION= 1.0.0
+DISTVERSIONPREFIX= v
+CATEGORIES= sysutils
+
+MAINTAINER= yamagi@yamagi.org
+COMMENT= Displays the CPUs current power consumption
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= yamagi
+GH_TAGNAME= ${DISTVERSIONPREFIX}${PORTVERSION}
+
+USES= gmake
+
+PLIST_FILES= man/man8/powermon.8.gz sbin/powermon
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/release/powermon \
+ ${STAGEDIR}${PREFIX}/sbin/powermon
+ ${INSTALL_MAN} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/misc/powermon.8 \
+ ${STAGEDIR}${MANPREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/sysutils/powermon/distinfo b/sysutils/powermon/distinfo
new file mode 100644
index 000000000000..71660bd9c11e
--- /dev/null
+++ b/sysutils/powermon/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1499099312
+SHA256 (yamagi-powermon-v1.0.0_GH0.tar.gz) = 7e0c3b988c797ac90a0fb2bc6db14fb1e307075d9792c68d99d26e64f58c1fb9
+SIZE (yamagi-powermon-v1.0.0_GH0.tar.gz) = 16348
diff --git a/sysutils/powermon/pkg-descr b/sysutils/powermon/pkg-descr
new file mode 100644
index 000000000000..53408f878b9e
--- /dev/null
+++ b/sysutils/powermon/pkg-descr
@@ -0,0 +1,10 @@
+Powermon is a small utility that reads the CPU internal power counters,
+calculates the current power consumption and displays it together with
+some nice statistics on an interactive curses interface.
+
+All Intel CPUs starting with Sandy Bridge are supported. Older Intel
+CPUs and CPUs from other vendors don't expose the necessary performance
+counters. Additionally some server CPUs like those based on Haswell and
+Broadwell do not provide the necessary data.
+
+WWW: https://github.com/Yamagi/powermon