aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-azure-cli-extension
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2019-01-26 13:28:29 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2019-01-26 13:28:29 +0000
commitcca9328bc1be518fc36a4955c04cd15cd4754414 (patch)
tree7d21ecc015d835632f8737f86e1f464949bfaa3e /sysutils/py-azure-cli-extension
parent4db9af1d348f8f6c1cc13905efca91758ee81e44 (diff)
downloadports-cca9328bc1be518fc36a4955c04cd15cd4754414.tar.gz
ports-cca9328bc1be518fc36a4955c04cd15cd4754414.zip
Notes
Diffstat (limited to 'sysutils/py-azure-cli-extension')
-rw-r--r--sysutils/py-azure-cli-extension/Makefile23
-rw-r--r--sysutils/py-azure-cli-extension/distinfo3
-rw-r--r--sysutils/py-azure-cli-extension/pkg-descr8
3 files changed, 34 insertions, 0 deletions
diff --git a/sysutils/py-azure-cli-extension/Makefile b/sysutils/py-azure-cli-extension/Makefile
new file mode 100644
index 000000000000..1873e69f93bf
--- /dev/null
+++ b/sysutils/py-azure-cli-extension/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= azure-cli-extension
+PORTVERSION= 0.2.3
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dbaio@FreeBSD.org
+COMMENT= Microsoft Azure Command-Line Tools Extension Command Module
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}azure-cli-core>=0:sysutils/py-azure-cli-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pip>=0:devel/py-pip@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0.30.0:devel/py-wheel@${PY_FLAVOR}
+
+USES= azurepy python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-azure-cli-extension/distinfo b/sysutils/py-azure-cli-extension/distinfo
new file mode 100644
index 000000000000..80aca2a02248
--- /dev/null
+++ b/sysutils/py-azure-cli-extension/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545608024
+SHA256 (azure-cli-extension-0.2.3.tar.gz) = 0c8d25912b83b374205d737ee078d3bf41f4476c210fef3aa3befc32de4016d6
+SIZE (azure-cli-extension-0.2.3.tar.gz) = 4873
diff --git a/sysutils/py-azure-cli-extension/pkg-descr b/sysutils/py-azure-cli-extension/pkg-descr
new file mode 100644
index 000000000000..4727d6035af4
--- /dev/null
+++ b/sysutils/py-azure-cli-extension/pkg-descr
@@ -0,0 +1,8 @@
+Microsoft Azure CLI 'extension' Command Module
+
+The Azure CLI is a command-line tool providing a great experience for managing
+Azure resources. The CLI is designed to make scripting easy, query data,
+support long-running operations, and more. Try it today and find out what the
+CLI has to offer!
+
+WWW: https://pypi.org/project/azure-cli-extension/