aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-azure-cli-role
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2019-01-26 13:28:29 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2019-01-26 13:28:29 +0000
commitcca9328bc1be518fc36a4955c04cd15cd4754414 (patch)
tree7d21ecc015d835632f8737f86e1f464949bfaa3e /sysutils/py-azure-cli-role
parent4db9af1d348f8f6c1cc13905efca91758ee81e44 (diff)
downloadports-cca9328bc1be518fc36a4955c04cd15cd4754414.tar.gz
ports-cca9328bc1be518fc36a4955c04cd15cd4754414.zip
Notes
Diffstat (limited to 'sysutils/py-azure-cli-role')
-rw-r--r--sysutils/py-azure-cli-role/Makefile26
-rw-r--r--sysutils/py-azure-cli-role/distinfo3
-rw-r--r--sysutils/py-azure-cli-role/pkg-descr8
3 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/py-azure-cli-role/Makefile b/sysutils/py-azure-cli-role/Makefile
new file mode 100644
index 000000000000..2120d0fc37ea
--- /dev/null
+++ b/sysutils/py-azure-cli-role/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= azure-cli-role
+PORTVERSION= 2.2.0
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dbaio@FreeBSD.org
+COMMENT= Microsoft Azure Command-Line Tools Role Command Module
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}azure-mgmt-authorization>=0.50.0:devel/py-azure-mgmt-authorization@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-mgmt-monitor>=0.5.2:devel/py-azure-mgmt-monitor@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-cli-core>=0:sysutils/py-azure-cli-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-graphrbac>=0.53.0:devel/py-azure-graphrbac@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-keyvault>=1.1.0:devel/py-azure-keyvault@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${PY_FLAVOR}
+
+USES= azurepy python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-azure-cli-role/distinfo b/sysutils/py-azure-cli-role/distinfo
new file mode 100644
index 000000000000..de1cc0ab3449
--- /dev/null
+++ b/sysutils/py-azure-cli-role/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545597396
+SHA256 (azure-cli-role-2.2.0.tar.gz) = 02dbfb38161041d0981e7f8f2b4774a9a08eb74702d2ca5ac2e0d4d1773fc887
+SIZE (azure-cli-role-2.2.0.tar.gz) = 30219
diff --git a/sysutils/py-azure-cli-role/pkg-descr b/sysutils/py-azure-cli-role/pkg-descr
new file mode 100644
index 000000000000..423e35dc3a9c
--- /dev/null
+++ b/sysutils/py-azure-cli-role/pkg-descr
@@ -0,0 +1,8 @@
+Microsoft Azure CLI 'role' Command Module
+
+The Azure CLI is a command-line tool providing a great experience for managing
+Azure resources. The CLI is designed to make scripting easy, query data,
+support long-running operations, and more. Try it today and find out what the
+CLI has to offer!
+
+WWW: https://pypi.org/project/azure-cli-role/