aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-cron-descriptor
diff options
context:
space:
mode:
authorFukang Chen <loader@FreeBSD.org>2020-01-08 02:46:31 +0000
committerFukang Chen <loader@FreeBSD.org>2020-01-08 02:46:31 +0000
commit75f1e509dcdc164d21c4f893da33ab94ade5b290 (patch)
tree15a768e5c5f874db2c275f792f3af6bd517461cf /sysutils/py-cron-descriptor
parentea6d3477dce07afbe4e271a02da33e106a4c5f4c (diff)
downloadports-75f1e509dcdc164d21c4f893da33ab94ade5b290.tar.gz
ports-75f1e509dcdc164d21c4f893da33ab94ade5b290.zip
[NEW PORT] sysutils/py-cron-descriptor: Converts cron expressions into human readable strings
A Python library that converts cron expressions into human readable strings. Ported to Python from https://github.com/bradyholt/cron-expression-descriptor. WWW: https://github.com/Salamek/cron-descriptor Reviewed by: koobs Approved by: koobs (ports) Differential Revision: https://reviews.freebsd.org/D23018
Notes
Notes: svn path=/head/; revision=522358
Diffstat (limited to 'sysutils/py-cron-descriptor')
-rw-r--r--sysutils/py-cron-descriptor/Makefile28
-rw-r--r--sysutils/py-cron-descriptor/distinfo3
-rw-r--r--sysutils/py-cron-descriptor/pkg-descr5
3 files changed, 36 insertions, 0 deletions
diff --git a/sysutils/py-cron-descriptor/Makefile b/sysutils/py-cron-descriptor/Makefile
new file mode 100644
index 000000000000..a3099ca34eeb
--- /dev/null
+++ b/sysutils/py-cron-descriptor/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= cron-descriptor
+PORTVERSION= 1.2.24
+CATEGORIES= sysutils python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= loader@FreeBSD.org
+COMMENT= Converts cron expressions into human readable strings
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flake8>0:devel/py-flake8@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pep8>0:devel/pep8@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pep8-naming>0:devel/py-pep8-naming@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist concurrent distutils
+
+GH_ACCOUNT= Salamek
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-cron-descriptor/distinfo b/sysutils/py-cron-descriptor/distinfo
new file mode 100644
index 000000000000..b7b0bb411e2c
--- /dev/null
+++ b/sysutils/py-cron-descriptor/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577866351
+SHA256 (Salamek-cron-descriptor-1.2.24_GH0.tar.gz) = 9b47d2e169f52293941bc64f57b3f6fef2e35f478c5bca5542388f7f6ed3d628
+SIZE (Salamek-cron-descriptor-1.2.24_GH0.tar.gz) = 32140
diff --git a/sysutils/py-cron-descriptor/pkg-descr b/sysutils/py-cron-descriptor/pkg-descr
new file mode 100644
index 000000000000..947f050b8c9b
--- /dev/null
+++ b/sysutils/py-cron-descriptor/pkg-descr
@@ -0,0 +1,5 @@
+A Python library that converts cron expressions into human
+readable strings. Ported to Python from
+https://github.com/bradyholt/cron-expression-descriptor.
+
+WWW: https://github.com/Salamek/cron-descriptor