aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-google-compute-engine
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-27 18:55:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-27 18:55:37 +0000
commit9065eb3a9d018df2893ad9db134c953b17c0e878 (patch)
tree0d36637254eb183b42d4f1eaf31db89189508357 /sysutils/py-google-compute-engine
parent07592b9dfe11749da52349337183a2f7508677c3 (diff)
downloadports-9065eb3a9d018df2893ad9db134c953b17c0e878.tar.gz
ports-9065eb3a9d018df2893ad9db134c953b17c0e878.zip
sysutils/py-google-compute-engine: Update 2.6.1 -> 2.7.6
Patch updates. PR: 227006 Submitted by: Helen Koike <helen.koike@collabora.com> (maintainer)
Notes
Notes: svn path=/head/; revision=465736
Diffstat (limited to 'sysutils/py-google-compute-engine')
-rw-r--r--sysutils/py-google-compute-engine/Makefile5
-rw-r--r--sysutils/py-google-compute-engine/distinfo6
-rw-r--r--sysutils/py-google-compute-engine/files/patch-google__compute__engine_instance__setup_instance__config.py6
-rw-r--r--sysutils/py-google-compute-engine/files/patch-google__compute__engine_network__setup_network__setup.py27
-rw-r--r--sysutils/py-google-compute-engine/files/patch-setup.py6
5 files changed, 11 insertions, 39 deletions
diff --git a/sysutils/py-google-compute-engine/Makefile b/sysutils/py-google-compute-engine/Makefile
index a640e431bcd7..8656dcc0b1fa 100644
--- a/sysutils/py-google-compute-engine/Makefile
+++ b/sysutils/py-google-compute-engine/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= google-compute-engine
-PORTVERSION= 2.6.1
+DISTVERSION= 2.7.6
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,6 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>0:devel/py-boto@${FLAVOR} \
USES= python
USE_PYTHON= autoplist concurrent distutils
+NO_ARCH= yes
USE_RC_SUBR= google_instance_setup \
google_network_setup \
@@ -27,8 +28,6 @@ USE_RC_SUBR= google_instance_setup \
google_ip_forwarding_daemon \
google_startup
-NO_ARCH= yes
-
SUB_LIST= PYTHON_CMD="${PYTHON_CMD}"
REINPLACE_ARGS= -i ''
diff --git a/sysutils/py-google-compute-engine/distinfo b/sysutils/py-google-compute-engine/distinfo
index 413402430bed..0ff3d5b8eeb1 100644
--- a/sysutils/py-google-compute-engine/distinfo
+++ b/sysutils/py-google-compute-engine/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1506375280
-SHA256 (google-compute-engine-2.6.1.tar.gz) = e1df14f755dfa8f165b7bde77b9ed0c18cc32c41a7eb4bf97bc73f0bb65e541f
-SIZE (google-compute-engine-2.6.1.tar.gz) = 29562
+TIMESTAMP = 1522049559
+SHA256 (google-compute-engine-2.7.6.tar.gz) = 23c764f2fc72db5a0b81cb8f8029c4e5d152bd50faf1eb7322b4a4cff039d003
+SIZE (google-compute-engine-2.7.6.tar.gz) = 40742
diff --git a/sysutils/py-google-compute-engine/files/patch-google__compute__engine_instance__setup_instance__config.py b/sysutils/py-google-compute-engine/files/patch-google__compute__engine_instance__setup_instance__config.py
index be40c28552d2..1c9fe55d1349 100644
--- a/sysutils/py-google-compute-engine/files/patch-google__compute__engine_instance__setup_instance__config.py
+++ b/sysutils/py-google-compute-engine/files/patch-google__compute__engine_instance__setup_instance__config.py
@@ -1,9 +1,9 @@
---- google_compute_engine/instance_setup/instance_config.py.orig 2017-09-29 00:21:28 UTC
+--- google_compute_engine/instance_setup/instance_config.py.orig 2018-02-22 19:44:17 UTC
+++ google_compute_engine/instance_setup/instance_config.py
-@@ -72,11 +72,11 @@ class InstanceConfig(config_manager.Conf
- 'instance_id': '0',
+@@ -73,11 +73,11 @@ class InstanceConfig(config_manager.Conf
},
'InstanceSetup': {
+ 'host_key_types': 'ecdsa,ed25519,rsa',
- 'optimize_local_ssd': 'true',
+ 'optimize_local_ssd': 'false',
'network_enabled': 'true',
diff --git a/sysutils/py-google-compute-engine/files/patch-google__compute__engine_network__setup_network__setup.py b/sysutils/py-google-compute-engine/files/patch-google__compute__engine_network__setup_network__setup.py
deleted file mode 100644
index 7b09c14c9626..000000000000
--- a/sysutils/py-google-compute-engine/files/patch-google__compute__engine_network__setup_network__setup.py
+++ /dev/null
@@ -1,27 +0,0 @@
---- google_compute_engine/network_setup/network_setup.py.orig 2017-09-29 00:21:28 UTC
-+++ google_compute_engine/network_setup/network_setup.py
-@@ -107,12 +107,18 @@ class NetworkSetup(object):
- self.logger.info('Enabling the Ethernet interfaces %s.', interfaces)
- dhclient_command = ['dhclient']
- if os.path.exists(self.dhclient_script):
-- dhclient_command += ['-sf', self.dhclient_script]
-- try:
-- subprocess.check_call(dhclient_command + ['-x'] + interfaces)
-- subprocess.check_call(dhclient_command + interfaces)
-- except subprocess.CalledProcessError:
-- self.logger.warning('Could not enable interfaces %s.', interfaces)
-+ dhclient_conf = '/etc/dhclient.conf'
-+ if os.path.exists(dhclient_conf):
-+ subprocess.call('sed -i "" "/^script/d" ' + dhclient_conf, shell=True)
-+ subprocess.call('echo \'script "%s";\' >> %s' % (self.dhclient_script, dhclient_conf), shell=True)
-+ for interface in interfaces:
-+ try:
-+ subprocess.check_call(['ifconfig', interface, 'down', 'delete'])
-+ # wait previous dhclient to exit
-+ subprocess.check_call(['sleep', '3'])
-+ subprocess.check_call(dhclient_command + [interface])
-+ except subprocess.CalledProcessError:
-+ self.logger.warning('Could not enable interface %s.', interface)
-
- def _EnableNetworkInterfaces(self, interfaces):
- """Enable the list of network interfaces.
diff --git a/sysutils/py-google-compute-engine/files/patch-setup.py b/sysutils/py-google-compute-engine/files/patch-setup.py
index c236a8743e58..7d7f35b8da2f 100644
--- a/sysutils/py-google-compute-engine/files/patch-setup.py
+++ b/sysutils/py-google-compute-engine/files/patch-setup.py
@@ -1,10 +1,10 @@
---- setup.py.orig 2017-09-14 18:08:49 UTC
+--- setup.py.orig 2018-02-22 19:44:17 UTC
+++ setup.py
-@@ -30,7 +30,6 @@ setuptools.setup(
+@@ -34,7 +34,6 @@ setuptools.setup(
long_description='Google Compute Engine guest environment.',
name='google-compute-engine',
packages=setuptools.find_packages(),
- scripts=glob.glob('scripts/*'),
url='https://github.com/GoogleCloudPlatform/compute-image-packages',
- version='2.6.1',
+ version='2.7.6',
# Entry points create scripts in /usr/bin that call a function.