aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-google-compute-engine
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-05-13 10:05:26 +0000
committerSteve Wills <swills@FreeBSD.org>2019-05-13 10:05:26 +0000
commitd4dac523704653e3f287a312d215a1fd3ae3c722 (patch)
tree9ba3473033f7bd713eeca8bc3de562a5c8e53cf8 /sysutils/py-google-compute-engine
parent8ad9672196b90ba7cfca2a50fb8c0393bb5ed5dd (diff)
downloadports-d4dac523704653e3f287a312d215a1fd3ae3c722.tar.gz
ports-d4dac523704653e3f287a312d215a1fd3ae3c722.zip
sysutils/py-google-compute-engine: fix daemons in python 2.7 case
PR: 237845 Reviewed by: koobs Approved by: implicit (portmgr, python, jfi blanket) MFH: 2019Q2
Notes
Notes: svn path=/head/; revision=501547
Diffstat (limited to 'sysutils/py-google-compute-engine')
-rw-r--r--sysutils/py-google-compute-engine/Makefile18
-rw-r--r--sysutils/py-google-compute-engine/files/google_accounts_daemon.in2
-rw-r--r--sysutils/py-google-compute-engine/files/google_clock_skew_daemon.in2
-rw-r--r--sysutils/py-google-compute-engine/files/google_instance_setup.in2
-rw-r--r--sysutils/py-google-compute-engine/files/google_network_daemon.in2
-rw-r--r--sysutils/py-google-compute-engine/files/google_startup.in2
6 files changed, 13 insertions, 15 deletions
diff --git a/sysutils/py-google-compute-engine/Makefile b/sysutils/py-google-compute-engine/Makefile
index 57c297560658..54b19e27632f 100644
--- a/sysutils/py-google-compute-engine/Makefile
+++ b/sysutils/py-google-compute-engine/Makefile
@@ -2,7 +2,7 @@
PORTNAME= google-compute-engine
DISTVERSION= 2.8.13
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -25,24 +25,22 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}distro>0:sysutils/py-distro@${PY_FLAVOR}
USES= python shebangfix
USE_PYTHON= autoplist concurrent distutils
-WRKSRC_SUBDIR= packages/python-google-compute-engine
+WRKSRC_SUBDIR= packages/python-google-compute-engine
NO_ARCH= yes
-SHEBANG_FILES= ../google-compute-engine/src/usr/bin/google_set_multiqueue \
- ../google-compute-engine/src/usr/bin/google_optimize_local_ssd
+SHEBANG_FILES= ../google-compute-engine/src/usr/bin/google_optimize_local_ssd \
+ ../google-compute-engine/src/usr/bin/google_set_multiqueue
USE_GITHUB= yes
GH_ACCOUNT= GoogleCloudPlatform
GH_PROJECT= compute-image-packages
GH_TAGNAME= 20190416
-USE_RC_SUBR= google_instance_setup \
- google_accounts_daemon \
- google_clock_skew_daemon \
- google_network_daemon \
- google_startup
+USE_RC_SUBR= google_accounts_daemon google_clock_skew_daemon \
+ google_instance_setup google_network_daemon google_startup
-SUB_LIST= PYTHON_CMD="${PYTHON_CMD}"
+SUB_LIST= PYTHON_CMD="${PYTHON_CMD}" \
+ PYTHON_VER="${PYTHON_VER}"
REINPLACE_ARGS= -i ''
post-install:
diff --git a/sysutils/py-google-compute-engine/files/google_accounts_daemon.in b/sysutils/py-google-compute-engine/files/google_accounts_daemon.in
index d6b6fa4b8e5c..bc7f60c003b2 100644
--- a/sysutils/py-google-compute-engine/files/google_accounts_daemon.in
+++ b/sysutils/py-google-compute-engine/files/google_accounts_daemon.in
@@ -24,7 +24,7 @@ load_rc_config "${name}"
: ${google_accounts_daemon_enable:="NO"}
command_interpreter="%%PYTHON_CMD%%"
-command=%%PREFIX%%/bin/${name}
+command=%%PREFIX%%/bin/${name}-%%PYTHON_VER%%
pidfile=/var/run/${name}.pid
start_cmd="google_accounts_daemon_start"
diff --git a/sysutils/py-google-compute-engine/files/google_clock_skew_daemon.in b/sysutils/py-google-compute-engine/files/google_clock_skew_daemon.in
index 66a71daa0c15..1cb56c19df2a 100644
--- a/sysutils/py-google-compute-engine/files/google_clock_skew_daemon.in
+++ b/sysutils/py-google-compute-engine/files/google_clock_skew_daemon.in
@@ -21,7 +21,7 @@ load_rc_config "${name}"
: ${google_clock_skew_daemon_enable:="NO"}
command_interpreter="%%PYTHON_CMD%%"
-command=%%PREFIX%%/bin/${name}
+command=%%PREFIX%%/bin/${name}-%%PYTHON_VER%%
pidfile=/var/run/${name}.pid
start_cmd="google_clock_skew_daemon_start"
diff --git a/sysutils/py-google-compute-engine/files/google_instance_setup.in b/sysutils/py-google-compute-engine/files/google_instance_setup.in
index 689fbbf45728..39c368f0b77c 100644
--- a/sysutils/py-google-compute-engine/files/google_instance_setup.in
+++ b/sysutils/py-google-compute-engine/files/google_instance_setup.in
@@ -21,7 +21,7 @@ load_rc_config "${name}"
: ${google_instance_setup_enable:="NO"}
command_interpreter="%%PYTHON_CMD%%"
-command=%%PREFIX%%/bin/${name}
+command=%%PREFIX%%/bin/${name}-%%PYTHON_VER%%
pidfile=/var/run/${name}.pid
run_rc_command "$1"
diff --git a/sysutils/py-google-compute-engine/files/google_network_daemon.in b/sysutils/py-google-compute-engine/files/google_network_daemon.in
index da9b44538519..8944b8a70ac7 100644
--- a/sysutils/py-google-compute-engine/files/google_network_daemon.in
+++ b/sysutils/py-google-compute-engine/files/google_network_daemon.in
@@ -21,7 +21,7 @@ load_rc_config "${name}"
: ${google_network_daemon_enable:="NO"}
command_interpreter="%%PYTHON_CMD%%"
-command=%%PREFIX%%/bin/${name}
+command=%%PREFIX%%/bin/${name}-%%PYTHON_VER%%
pidfile=/var/run/${name}.pid
start_cmd="google_network_daemon_start"
diff --git a/sysutils/py-google-compute-engine/files/google_startup.in b/sysutils/py-google-compute-engine/files/google_startup.in
index a3fd8004d557..1e6a8531d03b 100644
--- a/sysutils/py-google-compute-engine/files/google_startup.in
+++ b/sysutils/py-google-compute-engine/files/google_startup.in
@@ -24,7 +24,7 @@ load_rc_config "${name}"
: ${google_startup_enable:="NO"}
command_interpreter="%%PYTHON_CMD%%"
-command=%%PREFIX%%/bin/google_metadata_script_runner
+command=%%PREFIX%%/bin/google_metadata_script_runner-%%PYTHON_VER%%
command_startup_args="--script-type startup"
command_shutdown_args="--script-type shutdown"
pidfile=/var/run/${name}.pid