aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-google-compute-engine
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-05-13 18:32:12 +0000
committerSteve Wills <swills@FreeBSD.org>2019-05-13 18:32:12 +0000
commite56f67821d507984a934ea018df587993586b9d4 (patch)
treee7213a73c7756b08822d39f1a33f9f001ec0f608 /sysutils/py-google-compute-engine
parent9ab84e02cb19621bcb367be320f27aeae4242ea2 (diff)
downloadports-e56f67821d507984a934ea018df587993586b9d4.tar.gz
ports-e56f67821d507984a934ea018df587993586b9d4.zip
sysutils/py-google-compute-engine: disable boto
This avoids breakage when running with python3 PR: 237877 Submitted by: Lucas Kanashiro <lucas.kanashiro@collabora.com> (maintainer) MFH: 2019Q2
Notes
Notes: svn path=/head/; revision=501581
Diffstat (limited to 'sysutils/py-google-compute-engine')
-rw-r--r--sysutils/py-google-compute-engine/Makefile5
-rw-r--r--sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample3
2 files changed, 5 insertions, 3 deletions
diff --git a/sysutils/py-google-compute-engine/Makefile b/sysutils/py-google-compute-engine/Makefile
index 54b19e27632f..0664a642429d 100644
--- a/sysutils/py-google-compute-engine/Makefile
+++ b/sysutils/py-google-compute-engine/Makefile
@@ -2,7 +2,7 @@
PORTNAME= google-compute-engine
DISTVERSION= 2.8.13
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= sysutils python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,8 +12,7 @@ COMMENT= Guest Environment for Google Compute Engine
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>0:devel/py-boto@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}netaddr>0:net/py-netaddr@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}netaddr>0:net/py-netaddr@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}netifaces>0:net/py-netifaces@${PY_FLAVOR} \
google_oslogin_control:sysutils/google-compute-engine-oslogin \
sudo:security/sudo
diff --git a/sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample b/sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample
index 0c018cc01407..68e85c3ccba5 100644
--- a/sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample
+++ b/sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample
@@ -12,3 +12,6 @@ default_shell = /bin/sh
[InstanceSetup]
set_multiqueue = false
optimize_local_ssd = false
+# google-cloud-sdk only supports python2 at the moment, disabling boto will
+# avoid issues when running this agent with python3.
+set_boto_config = false