aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-ploy
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-07-07 13:52:30 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-07-07 13:52:30 +0000
commit6ca65b4d61b1af4ae24a6f5d68a22a025358ba5d (patch)
treeb8a10cc44dfcbbec07a9f19c31434908988a3df6 /sysutils/py-ploy
parent3fa9f96c9387680fd11b10b69d8815e45374c4b5 (diff)
downloadports-6ca65b4d61b1af4ae24a6f5d68a22a025358ba5d.tar.gz
ports-6ca65b4d61b1af4ae24a6f5d68a22a025358ba5d.zip
[NEW] sysutils/py-ploy: Manage servers through a central configuration
Ploy is a commandline-tool to provision, manage and control server instances. What kind of server instances these are depends on the used plugins. There are plugins for EC2 (ploy_ec2), FreeBSD Jails (ploy_ezjail) and more. You can create, delete, monitor and ssh into instances while ploy handles the details like ssh fingerprint checking. Additional plugins provide advanced functionality like integrating Fabric (ploy_fabric) and Ansible (ploy_ansible). WWW: http://ploy.readthedocs.org
Notes
Notes: svn path=/head/; revision=361086
Diffstat (limited to 'sysutils/py-ploy')
-rw-r--r--sysutils/py-ploy/Makefile23
-rw-r--r--sysutils/py-ploy/distinfo2
-rw-r--r--sysutils/py-ploy/pkg-descr9
-rw-r--r--sysutils/py-ploy/pkg-plist1
4 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/py-ploy/Makefile b/sysutils/py-ploy/Makefile
new file mode 100644
index 000000000000..96230966ca33
--- /dev/null
+++ b/sysutils/py-ploy/Makefile
@@ -0,0 +1,23 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ploy
+DISTVERSION= 1.0rc11
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Manage servers through a central configuration
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lazy>0:${PORTSDIR}/devel/py-lazy \
+ ${PYTHON_PKGNAMEPREFIX}paramiko>0:${PORTSDIR}/security/py-paramiko
+
+USES= zip
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-ploy/distinfo b/sysutils/py-ploy/distinfo
new file mode 100644
index 000000000000..3bb3f96c04f0
--- /dev/null
+++ b/sysutils/py-ploy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ploy-1.0rc11.zip) = e33f050a59c6ecce65cb16982d905901c89e29d23ac440781a2554b93c94260d
+SIZE (ploy-1.0rc11.zip) = 51232
diff --git a/sysutils/py-ploy/pkg-descr b/sysutils/py-ploy/pkg-descr
new file mode 100644
index 000000000000..a3de9902e9fb
--- /dev/null
+++ b/sysutils/py-ploy/pkg-descr
@@ -0,0 +1,9 @@
+Ploy is a commandline-tool to provision, manage and control server instances.
+What kind of server instances these are depends on the used plugins. There
+are plugins for EC2 (ploy_ec2), FreeBSD Jails (ploy_ezjail) and more.
+
+You can create, delete, monitor and ssh into instances while ploy handles the
+details like ssh fingerprint checking. Additional plugins provide advanced
+functionality like integrating Fabric (ploy_fabric) and Ansible (ploy_ansible).
+
+WWW: http://ploy.readthedocs.org
diff --git a/sysutils/py-ploy/pkg-plist b/sysutils/py-ploy/pkg-plist
new file mode 100644
index 000000000000..8fb5cc4556d5
--- /dev/null
+++ b/sysutils/py-ploy/pkg-plist
@@ -0,0 +1 @@
+@comment $FreeBSD$