aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-python-nomad
diff options
context:
space:
mode:
authorJohn Hixson <jhixson@FreeBSD.org>2019-01-29 03:50:17 +0000
committerJohn Hixson <jhixson@FreeBSD.org>2019-01-29 03:50:17 +0000
commit07e7815f85319a803231f2cf8c49c39fa79797fd (patch)
treed3bfb71f6441fc11292afd98b06a7107412ebf8a /sysutils/py-python-nomad
parent0ac79a789738457cce26a663f09bf911223698f3 (diff)
Notes
Diffstat (limited to 'sysutils/py-python-nomad')
-rw-r--r--sysutils/py-python-nomad/Makefile25
-rw-r--r--sysutils/py-python-nomad/distinfo3
-rw-r--r--sysutils/py-python-nomad/pkg-descr9
3 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/py-python-nomad/Makefile b/sysutils/py-python-nomad/Makefile
new file mode 100644
index 000000000000..52e92f98e5dd
--- /dev/null
+++ b/sysutils/py-python-nomad/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= python-nomad
+PORTVERSION= 0.5.0
+CATEGORIES= sysutils python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jhixson@FreeBSD.org
+COMMENT= Python client for nomad
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.10.0:www/py-requests@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.10.0:www/py-requests@${PY_FLAVOR}
+
+USES= python:3.3+
+
+USE_GITHUB= yes
+GH_ACCOUNT= jrxFive
+GH_PROJECT= python-nomad
+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-python-nomad/distinfo b/sysutils/py-python-nomad/distinfo
new file mode 100644
index 000000000000..55b1f8ea7adc
--- /dev/null
+++ b/sysutils/py-python-nomad/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1507912742
+SHA256 (jrxFive-python-nomad-0.5.0_GH0.tar.gz) = 1ba2acab7995f0a504bdeea0df06f6ce93c60c1faacfa49b10bc2bb146a8d5ad
+SIZE (jrxFive-python-nomad-0.5.0_GH0.tar.gz) = 16255
diff --git a/sysutils/py-python-nomad/pkg-descr b/sysutils/py-python-nomad/pkg-descr
new file mode 100644
index 000000000000..c9aab548eee8
--- /dev/null
+++ b/sysutils/py-python-nomad/pkg-descr
@@ -0,0 +1,9 @@
+Python client for nomad (WWW: http://www.nomadproject.io)
+
+Nomad is a tool for managing a cluster of machines and running
+applications on them.
+Nomad abstracts away machines and the location of applications,
+and instead enables users to declare what they want to run and
+Nomad handles where they should run and how to run them.
+
+WWW: https://github.com/jrxFive/python-nomad