aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-pytsk/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-11-25 22:09:51 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-11-25 22:09:51 +0000
commitd86e43e7c86cca0ad2726f05d6d07b48435b8731 (patch)
treeb4649a40e48b963876e94a679d596e199a5c9925 /sysutils/py-pytsk/Makefile
parentdbaeeeeb71a1d88c4337bb9f1803ad654e570256 (diff)
downloadports-d86e43e7c86cca0ad2726f05d6d07b48435b8731.tar.gz
ports-d86e43e7c86cca0ad2726f05d6d07b48435b8731.zip
Notes
Diffstat (limited to 'sysutils/py-pytsk/Makefile')
-rw-r--r--sysutils/py-pytsk/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/sysutils/py-pytsk/Makefile b/sysutils/py-pytsk/Makefile
index 9b848eb9db84..0ed466de19c5 100644
--- a/sysutils/py-pytsk/Makefile
+++ b/sysutils/py-pytsk/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pytsk
-DISTVERSION= 2013-09-10
-PORTREVISION= 1
+DISTVERSION= 2013-11-24
CATEGORIES= sysutils security devel python
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,16 +17,17 @@ LIB_DEPENDS= libtsk.so:${PORTSDIR}/sysutils/sleuthkit
WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= shebangfix
+SHEBANG_FILES= samples/*.py
+python_OLD_CMD= .*
+python_CMD= ${PYTHON_CMD}
USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME=pytsk3
-PYDISTUTILS_PKGVERSION=0.1
+PYDISTUTILS_PKGVERSION=4.1.2
post-patch:
- ${REINPLACE_CMD} -e '/socket\.h/ { h; s|socket|types|; G; }' ${WRKSRC}/misc.h
- ${REINPLACE_CMD} -e 's|/usr/local/include/tsk/|${LOCALBASE}/include/tsk/|' \
- -e "s|LIBRARY_DIRS = \[\]|LIBRARY_DIRS = ['${LOCALBASE}/lib']|" \
- -e "s|= \[CONFIG\['TSK_HEADERS_LOCATION'\]\]|= ['${LOCALBASE}/include']|" \
+ ${REINPLACE_CMD} -e "s|'/', 'usr', 'local'|'${LOCALBASE}'|" \
${WRKSRC}/setup.py
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}