aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-pytsk
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-02-03 09:50:38 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-02-03 09:50:38 +0000
commit69dc41f55fc4fafdb8f97da5caa15003a7bcb6c5 (patch)
tree655155674c3cc448dd67901859b14b1d86edc670 /sysutils/py-pytsk
parent0a579f63ca782e2887f3324f2b4cc350577788df (diff)
downloadports-69dc41f55fc4fafdb8f97da5caa15003a7bcb6c5.tar.gz
ports-69dc41f55fc4fafdb8f97da5caa15003a7bcb6c5.zip
Update to 20190121
Notes
Notes: svn path=/head/; revision=492040
Diffstat (limited to 'sysutils/py-pytsk')
-rw-r--r--sysutils/py-pytsk/Makefile6
-rw-r--r--sysutils/py-pytsk/distinfo6
-rw-r--r--sysutils/py-pytsk/files/patch-setup.py8
3 files changed, 10 insertions, 10 deletions
diff --git a/sysutils/py-pytsk/Makefile b/sysutils/py-pytsk/Makefile
index b0768a54c52b..d9fe816858fe 100644
--- a/sysutils/py-pytsk/Makefile
+++ b/sysutils/py-pytsk/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= pytsk
-PORTVERSION= 20190103
+PORTVERSION= 20190121
CATEGORIES= sysutils security devel python
-MASTER_SITES= CHEESESHOP
-# https://github.com/py4n6/pytsk/releases/download/${PORTVERSION}/
+MASTER_SITES= CHEESESHOP \
+ https://github.com/py4n6/pytsk/releases/download/${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}3-${PORTVERSION}
diff --git a/sysutils/py-pytsk/distinfo b/sysutils/py-pytsk/distinfo
index 6f99df5bfba3..bc48c6cfbcda 100644
--- a/sysutils/py-pytsk/distinfo
+++ b/sysutils/py-pytsk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1546525493
-SHA256 (pytsk3-20190103.tar.gz) = c306d441d693da6cd26ce0f0cd96cec8094392a92d61cd474db28b9c19f46d8f
-SIZE (pytsk3-20190103.tar.gz) = 2993563
+TIMESTAMP = 1548138834
+SHA256 (pytsk3-20190121.tar.gz) = ca7bb133d34f504d09b67c34be1e8d0965e1141a7fc8a2763cb4d046a870a629
+SIZE (pytsk3-20190121.tar.gz) = 3180752
diff --git a/sysutils/py-pytsk/files/patch-setup.py b/sysutils/py-pytsk/files/patch-setup.py
index db3bf2c4c0ad..9ab723c4a50b 100644
--- a/sysutils/py-pytsk/files/patch-setup.py
+++ b/sysutils/py-pytsk/files/patch-setup.py
@@ -1,8 +1,8 @@
# Unbundle sleuthkit and talloc
---- setup.py.orig 2019-01-03 11:50:09 UTC
+--- setup.py.orig 2019-01-21 19:31:43 UTC
+++ setup.py
-@@ -179,9 +179,9 @@ class BuildExtCommand(build_ext):
+@@ -230,9 +230,9 @@ class BuildExtCommand(build_ext):
def run(self):
compiler = new_compiler(compiler=self.compiler)
# pylint: disable=attribute-defined-outside-init
@@ -14,7 +14,7 @@
if not os.access("pytsk3.c", os.R_OK):
# Generate the Python binding code (pytsk3.c).
-@@ -351,7 +351,7 @@ class ProjectBuilder(object):
+@@ -402,7 +402,7 @@ class ProjectBuilder(object):
self._argv = argv
# The path to the sleuthkit/tsk directory.
@@ -23,7 +23,7 @@
# Paths under the sleuthkit/tsk directory which contain files we need
# to compile.
-@@ -361,13 +361,13 @@ class ProjectBuilder(object):
+@@ -412,13 +412,13 @@ class ProjectBuilder(object):
# The args for the extension builder.
self.extension_args = {
"define_macros": [],