aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-salt
diff options
context:
space:
mode:
authorBrad Davis <brd@FreeBSD.org>2017-02-17 15:59:58 +0000
committerBrad Davis <brd@FreeBSD.org>2017-02-17 15:59:58 +0000
commit7472c5e220bafa2495efed036a03d85b10027fa7 (patch)
treeb8d97eb211652d04ce22171edd4b75a5d2b83466 /sysutils/py-salt
parent211101f7848a44054585574aa3a78d581109bedb (diff)
downloadports-7472c5e220bafa2495efed036a03d85b10027fa7.tar.gz
ports-7472c5e220bafa2495efed036a03d85b10027fa7.zip
sysutils/py-salt: Teach the Salt master and minion startup scripts to set
pidfile=. On a restart this will cause the rc framework to wait for the processes to exit before trying to start, instead of failing to start because the previous processes have not gone away yet. PR: 217154 Approved by: Christer Edwards <christer.edwards@gmail.com> (maintainer), bdrewery (mentor, implicit)
Notes
Notes: svn path=/head/; revision=434287
Diffstat (limited to 'sysutils/py-salt')
-rw-r--r--sysutils/py-salt/Makefile2
-rw-r--r--sysutils/py-salt/files/salt_master.in2
-rw-r--r--sysutils/py-salt/files/salt_minion.in2
3 files changed, 5 insertions, 1 deletions
diff --git a/sysutils/py-salt/Makefile b/sysutils/py-salt/Makefile
index b3690dc13262..f5a0c49efac3 100644
--- a/sysutils/py-salt/Makefile
+++ b/sysutils/py-salt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= salt
PORTVERSION= 2016.11.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/sysutils/py-salt/files/salt_master.in b/sysutils/py-salt/files/salt_master.in
index 5f9181a435aa..6ff79eecc366 100644
--- a/sysutils/py-salt/files/salt_master.in
+++ b/sysutils/py-salt/files/salt_master.in
@@ -27,12 +27,14 @@ load_rc_config ${name}
: ${salt_master_enable:=NO}
: ${salt_master_paths=/sbin:/bin:/usr/sbin:/usr/bin:%%PREFIX%%/bin:%%PREFIX%%/sbin}
+: ${salt_master_pidfile:=/var/run/salt-master.pid}
: ${salt_master_eggcache=/tmp}
command="%%PREFIX%%/bin/salt-master"
command_interpreter="%%PYTHON_CMD%%"
required_files="%%PREFIX%%/etc/salt"
command_args="-c ${required_files} -d"
+pidfile=${salt_master_pidfile}
export PATH="${salt_master_paths}"
export PYTHON_EGG_CACHE="${salt_master_eggcache}"
diff --git a/sysutils/py-salt/files/salt_minion.in b/sysutils/py-salt/files/salt_minion.in
index 189fbd8d5427..8ceab7e8a71d 100644
--- a/sysutils/py-salt/files/salt_minion.in
+++ b/sysutils/py-salt/files/salt_minion.in
@@ -27,12 +27,14 @@ load_rc_config ${name}
: ${salt_minion_enable:=NO}
: ${salt_minion_paths=/sbin:/bin:/usr/sbin:/usr/bin:%%PREFIX%%/bin:%%PREFIX%%/sbin}
+: ${salt_minion_pidfile:=/var/run/salt-minion.pid}
: ${salt_minion_eggcache=/tmp}
command="%%PREFIX%%/bin/salt-minion"
command_interpreter="%%PYTHON_CMD%%"
required_files="%%PREFIX%%/etc/salt"
command_args="-c ${required_files} -d"
+pidfile=${salt_minion_pidfile}
export PATH="${salt_minion_paths}"
export PYTHON_EGG_CACHE="${salt_minion_eggcache}"